Engine noise in 2007 G-6 - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-24-2011, 05:47 AM Thread Starter
Junior Member
 
Join Date: Aug 2011
Posts: 3
 
Engine noise in 2007 G-6

I'm new to the G-6 - just bought mine a month ago. 2007 G6 4cyl - love the car BUT I have a problem.

When I first start the car the motor sounds like it has no oil in it for about 3 seconds then it is fine. My warranty runs out very soon and am hoping this is not a bearing problem - maybe just an oil pump or something?
jostep41 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-24-2011, 04:11 PM
Lifetime Member
 
geewhiz's Avatar
 
Join Date: May 2008
Posts: 3,269
 
Hi welcome aboard!
Have you check the oil level?




Mike
MODS;
None, if I want a faster car I'll buy one.
geewhiz is offline  
post #3 of 3 (permalink) Old 08-25-2011, 03:03 PM Thread Starter
Junior Member
 
Join Date: Aug 2011
Posts: 3
 
Hi geewhiz -

yes I did check the oil and it is fine. I am due for an oil change in about 300 miles tho. The dealer wants to just put lucas in it when they change the oil. I have used lucas before and it does help a lot of issues but I don't want to just cover up an existing problem -if there is really a problem.

Think I should try the lucas?
jostep41 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > General Discussion > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007-3.5L v6- Engine Lag and Malfunctioning Temp Gauge thedrizzle52 Problems and Solutions 8 06-02-2011 09:31 PM
G6 GTP Engine noise!! HELP!!!! bethk Problems and Solutions 8 08-06-2010 07:01 AM
2007 GT 3.9L to 3.6L engine swap TGillman255 Powertrain Performance Modifications 13 04-01-2010 02:25 PM
2007 G6, 2.4L Engine Noise Dusty35 Problems and Solutions 13 02-24-2009 07:55 AM
wierd noise from engine bay jasonball Problems and Solutions 2 12-18-2008 06:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome