New Member, TheAlien - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 07-13-2014, 04:42 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Las Vegas
Age: 57
Posts: 11
 
New Member, TheAlien

Hello folks! Yeah, I'm new here. Bought a 2008 G6 convertible a little over two years ago. Love it...mostly. I'm having some minor problems with the engine at 1400-1600 rpms and thought I'd check out your forum and see if anyone has a solution other than replacing/cleaning the MAF. I'll dig around and see what I find.

I live in Vegas, and let me tell you, there is nothing like putting the top down, cranking the music, and riding up and down the strip on a warm summer evening (which in Vegas, is usually around 102 degrees). Definitely not a top-down kind of place in the daytime. Burn your scalp right off!

I usually try and do my own repairs on my car, but sometimes I have to take it to the dealer, who sold me one of those worthless aftermarket warrantees. I highly recommend staying as far from this dealer as possible, btw. He wanted $250 to "Repair" not replace my headlamp (a wire was shorting out). I bought two really excellent new ones and just replaced both for $289.

I'm a huge computer geek, love playing games on Steam, especially the ones with gore AND story. I recently purchased a bluetooth ELM327 interface and trying to figure out what all the details mean. And even though my car stutters at the 1400-1600 rpm range, it's throwing no codes. But with you folks' help I'll figure it out.

Well, enough about me. I hope to get LOTS of interesting info from your site. Thank you for having me
TheAlien is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 07-13-2014, 06:12 PM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,348
    
Welcome aboard!!!

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
post #3 of 12 (permalink) Old 07-13-2014, 06:24 PM
Senior Member
 
G6GTConvertable's Avatar
 
Join Date: Jul 2014
Location: So Cal Near Temecula
Posts: 113
 
Welcome! Stay Cool!!!

I just bought a 2007 Red GT Convertible with 11,000 miles on it!
G6GTConvertable is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 07-13-2014, 08:18 PM
Senior Member
 
theshibbykumquat's Avatar
 
Join Date: Jan 2012
Posts: 447
 
Welcome to the club!

My Progression

Mods: BMD Performance Adjustable Front End Links, BMD Performance Stainless Steel Brake Lines, Koni Yellow Sport Dampers, Pedders Lowering Springs, Brembo Upgrade, Racingline STB, Custom Intake, 8000k Lowbeam HIDs, 10000k Foglight HIDs, Badge & Doorsill Overlays, GM G6 Logo Mats, Blacked Out Window Trim, Blacked Out Grills, Pioneer Headunit, 2 10" Kenwood Subs
theshibbykumquat is offline  
post #5 of 12 (permalink) Old 07-14-2014, 04:58 AM
Senior Member
 
mshinall's Avatar
 
Join Date: May 2010
Location: NoVA
Posts: 636
 
Welcome to the club! Lots of good info here. Could you give us some more detail about what exactly happens at 1400-1600?

Sent from AutoGuide.com App

2009 Techno Gray Metallic G6 GXP Sedan (3.6L Auto6 112K miles)
---
CRAB Intake Opt 3 w/FPU, Lloyds GXP floor mats, HIDs low 6000k 55w/fog 3000k 35w, LED DRLs behind lower grills, V3 Triton LED turn signal/reverse/brake, LED side markers/maps/dome/tag/trunk/high mount stop, 2 coats niteshades on tails, Tint 35% all around, Debadged (except arrows), PAC IPod and BT adapters, PowerStop D/S rotors and ceramic pads, Resonator repl w/24" cherry bomb, Racingline STB, Big 3 Upgrade, Optima Yellowtop D75/25, Blacked out arrows, chrome window trim and black dipped wheels, KYB struts and shocks, CM lowering springs, Cherry Bomb Vortex Crossflow muffler, 2.5" pipe from axle back, two 4" stainless double walled slant tips
...still working...
mshinall is offline  
post #6 of 12 (permalink) Old 07-15-2014, 07:15 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Las Vegas
Age: 57
Posts: 11
 
Thanks for the welcome guys

As for what the car does: Well, mostly just a literal stutter, like stepping on a garden hose but really quick. Sometimes, especially after driving a bit (over 10 minutes), it gets a lot worse and can buck like a bronco. All of this only happens if I'm giving it just a little gas and on any kind of an incline. There have been occasions when I've heard it backfire through the engine (as opposed to the exhaust), kind like a puff sound. And sometimes on the way home, when I come off the exit ramp from a dead stop, I have to do all but stomp the accelerator to get it past the stutter/puff stage.

That's pretty much it. Other than that, it runs fantastic. Well, maybe a slight hesitation when going into passing gear, but I kind of expect that. I've replaced the MAF, so the next thing is this weekend taking it to replace plugs and wires, just in case. It probably needs it anyhow. I'm at 90k and had it since 70k and know it hasn't been done since I got it.

Thanks for any suggestions.
TheAlien is offline  
post #7 of 12 (permalink) Old 07-20-2014, 11:15 AM
Senior Member
 
mshinall's Avatar
 
Join Date: May 2010
Location: NoVA
Posts: 636
 
Do the plugs and wires, run some seafoam through the gas tank, and replace the air filter if it needs to be.

Sent from AutoGuide.com App

2009 Techno Gray Metallic G6 GXP Sedan (3.6L Auto6 112K miles)
---
CRAB Intake Opt 3 w/FPU, Lloyds GXP floor mats, HIDs low 6000k 55w/fog 3000k 35w, LED DRLs behind lower grills, V3 Triton LED turn signal/reverse/brake, LED side markers/maps/dome/tag/trunk/high mount stop, 2 coats niteshades on tails, Tint 35% all around, Debadged (except arrows), PAC IPod and BT adapters, PowerStop D/S rotors and ceramic pads, Resonator repl w/24" cherry bomb, Racingline STB, Big 3 Upgrade, Optima Yellowtop D75/25, Blacked out arrows, chrome window trim and black dipped wheels, KYB struts and shocks, CM lowering springs, Cherry Bomb Vortex Crossflow muffler, 2.5" pipe from axle back, two 4" stainless double walled slant tips
...still working...
mshinall is offline  
post #8 of 12 (permalink) Old 07-20-2014, 11:43 AM
Moderator
 
waterfowler76's Avatar
 
Join Date: May 2009
Location: Las Vegas
Posts: 4,022
 
Send a message via Yahoo to waterfowler76
Welcome to the club! Im also in Vegas and have had the same problem in the past. Its back fired on me a few times over the years. Any time my intake temp is over 120 my car runs like shit. When it hits over 150 thats when it starts to lag. Once cooler temps hit I never have problems. Ive changed the plugs, wires, coils and no change. Someone else on here had somewhat the same symptoms and they found the MAF wiring was bad.

2007 PONTIAC G6 GT

Waterfowler's 6 <---- Check out my 6
waterfowler76 is offline  
post #9 of 12 (permalink) Old 07-20-2014, 12:36 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Las Vegas
Age: 57
Posts: 11
 
Thanks for the tips. New wires and plugs coming Tuesday. I replaced the MAF and the filter, no change. Got the reader and it's not throwing any errors. And yeah, the hotter it is, the worse it gets. AND, as a side note, being diligent in the attempt at diagnosis, I noticed it HATES Shell gas for some reason. Runs like crap. The el-cheapo stuff at Terribles seems to be much better. Same octane, so that's not it. (and yeah, tried 3 different octanes and didn't make any difference) I can't wait until next weekend when I get the wires and plugs in. I hope that fixes it.

And just for fun, I had to put this in 'cause it made me laugh.
TheAlien is offline  
post #10 of 12 (permalink) Old 07-20-2014, 01:42 PM
Senior Member
 
mshinall's Avatar
 
Join Date: May 2010
Location: NoVA
Posts: 636
 
Good luck. Hope the new plugs or wires help.

Sent from AutoGuide.com App

2009 Techno Gray Metallic G6 GXP Sedan (3.6L Auto6 112K miles)
---
CRAB Intake Opt 3 w/FPU, Lloyds GXP floor mats, HIDs low 6000k 55w/fog 3000k 35w, LED DRLs behind lower grills, V3 Triton LED turn signal/reverse/brake, LED side markers/maps/dome/tag/trunk/high mount stop, 2 coats niteshades on tails, Tint 35% all around, Debadged (except arrows), PAC IPod and BT adapters, PowerStop D/S rotors and ceramic pads, Resonator repl w/24" cherry bomb, Racingline STB, Big 3 Upgrade, Optima Yellowtop D75/25, Blacked out arrows, chrome window trim and black dipped wheels, KYB struts and shocks, CM lowering springs, Cherry Bomb Vortex Crossflow muffler, 2.5" pipe from axle back, two 4" stainless double walled slant tips
...still working...
mshinall is offline  
post #11 of 12 (permalink) Old 07-28-2014, 08:57 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Las Vegas
Age: 57
Posts: 11
 
Well, finally got my plugs and wires installed today, Taylor ThunderVolt 8.2 wires and Pulstar plugs (both from CARiD). Guys, seriously, I have a new car. This runs better than the day I bought it. Not only does it not fart, burp, and give birth when trying to drive at 1500-1600 rpm, the darned thing has JUICE! Pulling out of the mechanic's lot, I actually burned rubber and DIDN'T MEAN TO! Absolutely amazing.

Now, do I know it was the plugs or wires that gave me that boost? No clue. It never ran this good and I bought it used. And I can see where one plug was not only burnt, but cracked, so there would be my main "Miss" issue. The remaining plugs were burnt pretty bad as well. But I have never imagined this car with this much "balls". I am Totally satisfied with this fix so far. I'll know more tomorrow when I run it to work in 105 degree Vegas heat, but I can't see there being an issue now. I'll update here if there is.

I also want to see if there is an improvement in gas mileage as well. Heck, it even shifts better now. I have no idea what one has to do with the other, other than the engine not being able to handle the pull on it, and just stuttering until it HAS to shift to compensate. I am such a HAPPY camper now .
TheAlien is offline  
post #12 of 12 (permalink) Old 07-29-2014, 05:30 PM
Senior Member
 
mshinall's Avatar
 
Join Date: May 2010
Location: NoVA
Posts: 636
 
Nice to hear! Its like Christmas in July!

Sent from AutoGuide.com App

2009 Techno Gray Metallic G6 GXP Sedan (3.6L Auto6 112K miles)
---
CRAB Intake Opt 3 w/FPU, Lloyds GXP floor mats, HIDs low 6000k 55w/fog 3000k 35w, LED DRLs behind lower grills, V3 Triton LED turn signal/reverse/brake, LED side markers/maps/dome/tag/trunk/high mount stop, 2 coats niteshades on tails, Tint 35% all around, Debadged (except arrows), PAC IPod and BT adapters, PowerStop D/S rotors and ceramic pads, Resonator repl w/24" cherry bomb, Racingline STB, Big 3 Upgrade, Optima Yellowtop D75/25, Blacked out arrows, chrome window trim and black dipped wheels, KYB struts and shocks, CM lowering springs, Cherry Bomb Vortex Crossflow muffler, 2.5" pipe from axle back, two 4" stainless double walled slant tips
...still working...
mshinall is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > General Discussion > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New member Blue10CamaroSS New Member Introductions 17 07-19-2012 05:28 PM
New Member here.... GPG6Vert New Member Introductions 6 09-13-2009 10:41 AM
Hello All New Member Here! Bmurr33 Car Audio, Video and Security 5 02-20-2009 08:53 PM
New Member - A little about myself! :D cmurphy725 New Member Introductions 11 02-05-2009 08:13 PM
New Member Nightwatcher New Member Introductions 1 04-04-2008 09:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome