Not sure if I'm having problems? - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-22-2015, 09:22 PM Thread Starter
Junior Member
 
Join Date: May 2015
Posts: 1
 
Not sure if I'm having problems?

I bought my car about a year ago.
2007 Pontiac G6 3.6L V6

It had about 28k miles, now just over 34.

It doesn't seem to shift as smoothly as I remember it. It's gotten better in warmer weather, but it's like sometimes it sits in a gear where if I ease onto the pedal it just takes off really nicely, and other times even if I give it a lot of gas the gear transitions are kinda slow unless I feather the pedal.

Especially noticeable getting over a hump at about 60 when getting on the highway.

Any ideas?

It was in an accident prior to when I got it but i'm pretty sure it was just cosmetic, I got rear ended and found the rear bumped was all bondoed so they replaced it.
instantcoffee is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > General Discussion > New Member Introductions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'05 G6 problems. PeaceLoveandG6 Problems and Solutions 3 09-28-2012 10:20 PM
H.I.D problems mprc911 Problems and Solutions 9 02-04-2012 02:35 PM
G6 Problems Blackbird Problems and Solutions 3 04-06-2011 09:40 PM
G6 problems bajeffrey51 Powertrain Performance Modifications 4 03-04-2009 07:48 AM
New with problems and yes i used the search button, problems with electrical? TuKwick Problems and Solutions 1 02-13-2009 02:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome