A couple of issues... - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-16-2013, 06:36 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 3
 
A couple of issues...

i have a 2007 G6 GT, 107000 miles. CEl light has been on for months. 25 mpg town, 32-34 HWY...no loss on gas mileage. I changed the oil a few days ago, disconnected the battery and the CEL went out for two days. Now its back on. Is there a way to pull codes without reader, or do i need to go to autozone and have them read it..
Secondly, i have noticed a vibration/humming when i turn, mainly right. Any slight movement to the right causes the hum/vibration. Is my power steering pump going bad?
Finally, my left front tire area sounds loike it is gonna fly off when i first start driving. it goes away after a few miles, but it sounds like the drivers front tire is wobbly, or loose or something. Lug nuts are tight, no play in the tire either...is this a shock issue?

Any help is appreciated! Thanks
hshawn_31 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-16-2013, 07:04 PM
Senior Member
 
diehard345's Avatar
 
Join Date: Jul 2012
Posts: 121
 
I would take it to Autozone and get the codes ran. I have the SAME EXACT problem with my car vibrating when I turn. It the sound comes from the left front wheel. When I start driving and I hit a bump it sounds like it's loose or something.

08 G6 GT Coupe
diehard345 is offline  
post #3 of 4 (permalink) Old 01-17-2013, 06:46 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Posts: 3
 
hmm, mine does it when going straight too. tie rod maybe..? idk. I just know it goes away after a few miles.
hshawn_31 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-18-2013, 09:46 AM
Junior Member
 
Join Date: Jan 2013
Posts: 15
 
depending on what work you have done to the car mechanically (ie- CAI, exhaust mods..etc), that could be part of the reason it is throwing the CEL. You can go to a place like auto zone to hae them read the codes, but I always like doing it myself. There is a great bluetooth OBD2 scan tool that you can get on ebay for about $10-$15 and then you just have to download the app for your phone. You can scan to see what codes its throwing, look them up in the tool and even clear them. Its a much cheaper alternative to typical OBD2 readers. Here is the link to the one I bought: Bluetooth OBD2 Reader

As far as the shaking/vibrating goes- I had a similar instance with my right wheel about 25K ago. I found that my outer tie rod was bad. Also the rim/tire combo I had neede to be aligned and the wheels needed to be rebalanced. If you've lowered the car at all and havent had the car aligned then get that done. If the issue still persists then check the tie rods (jack up car and wiggle tire left to righ and up and down--if there is any play something needs to be replaced)
g6girlnj is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Technical Discussion & Modifications > General Maintenance > Maintenance Information

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
new with a couple of issues kyser Problems and Solutions 5 08-07-2011 12:05 PM
New from Chitown with couple ?'s. :) victoriamanda New Member Introductions 5 12-31-2010 10:16 AM
Just got my G6... couple ?'s datacat General Maintenance 5 02-12-2009 11:27 PM
A couple issues 07g6guy Problems and Solutions 2 08-21-2008 11:16 AM
Couple of Problems rakeshs_ca Problems and Solutions 26 05-10-2006 08:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome