horrible bump= no radio - Pontiac G6 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-18-2012, 03:15 PM Thread Starter
Junior Member
 
Join Date: Jun 2012
Posts: 1
 
Cool horrible bump= no radio

Hello I have a 2006 Pontiac G6. I had been having the normal cd player problems that I have seen multiple users post about. The cd player stopped playing cd's and also wouldn't reject or load them anymore. So I decided to go with XM radio. It worked great until today.... I was coming home from a day out and I usually try to avoid big bumps and holes in the road but there was a truck with a trailer so i couldn't swerve to miss it. As soon as i hit the bump my stereo went out. I have checked all of the fuses and didn't find anything wrong. The screen is completely blank no illumination or anything. The clock does come on however when i press the clock button so I know its not just that the screen stopped working. Anyways i'm going to try to unhook the battery and hook it back in and see if that will help but that is all i know to do to try to fix it. If yall have any advice i would greatly appreciate it.
pekabu37818 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-20-2012, 12:16 AM
OOBER SUPER MEMBER
 
CruisinG6's Avatar
 
Join Date: Jul 2009
Posts: 4,232
 
You can try removing the stereo to see if the connectors in the back have come loose. Although that's highly unlikely. It sounds to me like the stereo itself may be done. Something internal that I wouldn't know how to attack. Maybe now is a good time to go with an aftermarket stereo?
CruisinG6 is offline  
post #3 of 4 (permalink) Old 06-20-2012, 09:34 AM
Decepticon Extraordinaire
 
Lampoon's Avatar
 
Join Date: Sep 2005
Location: The Alamo
Posts: 5,348
    
Disconnect your battery for 15 min and let it all reset.

MODS:
Crab Intakes CAB, MPD Ram Air hood, Custom exhaust,
WAMS High Performance Tune and a whole lot more....

My Progession
Lampoon is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-20-2012, 10:31 AM
Junior Member
 
Join Date: May 2012
Posts: 4
 
Try the reset like Lampoon said but if you checked all the connections and fuses and they are all good it is probably an internal solder that has broke, thus radio is not working. You can try to look but it will be difficult to figure out what it is or what broke. Good Luck though
crazycanuk14 is offline  
Sponsored Links
Advertisement
 
Reply

  Pontiac G6 Forum > Announcements > FAQ

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Pontiac G6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
noise from right front on smallest bump la negra Problems and Solutions 5 07-22-2010 06:29 PM
Horrible Squeek punkrokgrl88 Problems and Solutions 2 04-08-2010 02:11 PM
Horrible Paint ProudG6Owner Automotive Cleaning and Detailing 24 07-14-2009 04:50 PM
bump in suspension roberts5831 Handle It! - Suspension, Wheel and Tire Modifications 1 06-14-2009 01:07 PM
Weird bump in under-radio pocket tahngarth Problems and Solutions 0 10-05-2005 09:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome