Pontiac G6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone, i have been a creeper on these forums ever since i got my used 06 G6 last year, however i was unable to creep my way out of this problem...

my car is showing the Engine Power Reduced message, this has happened once before and while a restart fixed the problem a month ago, i was not so lucky tonight... stranded in pittsgurgh for the night i thought i would try and tackle this problem while i wait for morning... after doing some digging i came across 2 threads.

http://www.g6ownersclub.com/forum/showthread.php?t=3655 - for the info
http://www.g6ownersclub.com/forum/showthread.php?t=7549 - for the manual

Since this appears to be an issue with my Throttle actuator control (the thing on the gas pedal?) can this be replaced/fixed, or is it something with the actual engine...

Salpac9 said he cleaned the Throttle body, was he talking about the TAC on the pedal? or actually taking out the throttle from the engine? Sorry im not the most mechanically inclined person and i would have posted in the "info" thread but it was 3 years old.

any help would be appreciated, im going to try and fix this tomorrow morning so i can make my 90 mile trek home :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4 (Edited)
solved... for now

after cleaning out the throttle body and disconnecting the battery to reset the computer i was still getting the error msg and no performance with stall-outs.

i remember coming across a thread that mentioned if you open the driver side door there is a compartment that houses wires for the Throttle/TAC whatever... i popped that open and saw droplets of water on the inside of the pannel, and sure enough on part of the wire connector (The long grey one 10+ pins, not the yellow one 4 pin i think)

disconnected and dried with some manual wind power and a paper towel and everything works... no error message/check engine light and thanks to cleaning out the throttle body a little extra pickup i think.

thanks for the help :D

edit: also made the trip home with no issues
 

·
Registered
Joined
·
2,388 Posts
First try cleaning the throttle body (many how-to vids on youtube) & clear the codes. If the code/s returns after that then replace the TB.

You should also clean the MAF sensor & change the air filter while you are at it.

The TB is on top of your engine at the end of the air inlet hose. I recommend you get the Chiltons for G6 book for 20 bucks or so.

Here's one vid on TB cleaning to give you the general idea:

 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
First try cleaning the throttle body (many how-to vids on youtube) & clear the codes. If the code/s returns after that then replace the TB.

You should also clean the MAF sensor & change the air filter while you are at it.

The TB is on top of your engine at the end of the air inlet hose. I recommend you get the Chiltons for G6 book for 20 bucks or so.

Here's one vid on TB cleaning to give you the general idea:

http://www.youtube.com/watch?v=41yFXjibtLY&feature=related
thanks for the advice, and after last night i will definitely be getting one of those books
 
1 - 6 of 6 Posts
Top