Pontiac G6 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have had this coupe for 5 years, 140K miles. Relatively maintenance free. My car was hesitant to start with last 3 recent drives. Attempted to start, no sound, replaced battery... thinking that was the problem. Now with the new battery, wont crank. Also, driver window did not close "gap". Attempted to use Actron code reader, no codes came up. If you have any suggestions, please let me know. Thank you very much
 

·
Registered
Joined
·
66 Posts
I'll ponder your no starting problem for a while. Any lights displayed? Will it crank in neutral? Just grabbing at straws here. Hopefully someone else will chime in soon.

As for the windows, they have to be "indexed" whenever the battery is disconnected. The procedure is in the owner's manual.

Mark
 

·
Registered
Joined
·
66 Posts
As for the windows, they have to be "indexed" whenever the battery is disconnected. The procedure is in the owner's manual.

Mark
Found the "indexing" procedure...(Applies only to coupes and convertibles.)

Do for each front door window:
1. Close door and raise window all the way up.
2. Hold the window switch up for two seconds after the window is closed. Release the switch, then hold the switch up again for two seconds.
3. Lower the window all the way down. Hold the switch down for two seconds.

Done.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I'll ponder your no starting problem for a while. Any lights displayed? Will it crank in neutral? Just grabbing at straws here. Hopefully someone else will chime in soon.

As for the windows, they have to be "indexed" whenever the battery is disconnected. The procedure is in the owner's manual.

Mark


Thanks for the input Mark. My engine light is the only light that stays on after attempted start. No crank in neutral. No codes came up with Actron code test.
 

·
Registered
Joined
·
93 Posts
Just so I understand correctly, as you've used 2 terms interchangeably.
The starter motor spins the motor, but the motor does NOT "fire up"
OR the starter motor does NOT spin the motor to be able to run?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Just so I understand correctly, as you've used 2 terms interchangeably.
The starter motor spins the motor, but the motor does NOT "fire up"
OR the starter motor does NOT spin the motor to be able to run?
No mechanical sounds, silence. No crank. Sorry
 

·
Registered
Joined
·
93 Posts
Agree'd about clutch pedal switch. But also make sure battery cable ends are clean.
Do you have other electrical function(lights , radio, wipers)?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Agree'd about clutch pedal switch. But also make sure battery cable ends are clean.
Do you have other electrical function(lights , radio, wipers)?
Agree'd about clutch pedal switch. But also make sure battery cable ends are clean.
Do you have other electrical function(lights , radio, wipers)?
We checked the battery cable ends, they're clean. I do have electrical function, radio/lights. Next step is checking the clutch pedal switch, thanks for a new direction. Will post updates and appreciate the time and input.
 
1 - 10 of 10 Posts
Top