Pontiac G6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I tried searching for similar problems to no avail so I was hoping that somebody could help me out. Recently the battery died on my '06 G6 and needed to be replaced. I put a new battery in but now the time and temp on the radio display disappear about 15 seconds after you turn the car on. All of the radio functions still work and hitting the display button will bring it back for 15 seconds but then it goes blank again. The only item that doesn’t shut off is what source the radio is in (ex FM1). Even more odd is when you turn the car off it magically reappears until you open the driver’s door. Any assistance with this would be greatly appreciated.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #2
I forgot to mention that the backlighting is working properly and all of the buttons are lit. Also, I realized that the time and temp only appear for about 5 seconds rather than the 15 that I originally said.
 

·
Registered
Joined
·
1 Posts
same problem

Hi, I was wondering if you figured out what was going wrong with your display. I am having the same problem after replacing the battery. All my other displays show except the clock/temp display. Did you find a solution?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
A few weeks after I replaced the battery it just started working again. Not sure what caused it or what made it start working again but its been fine ever since.
 
1 - 4 of 4 Posts
Top