Pontiac G6 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Help!?! New owner new to forum. Trying to fix my son's car. Extreme loss of power on acceleration, rpms don't go up, tops out at 40 mph. Throws codes p0010, p0449, p0300. Check engine light and on the way home the brake light and beeping comes on Everytime you push accelerator. Is it cam position sensors or solenoids or cat? Or ? Don't have the money to replace unnecessary parts. Any help would be greatly appreciated
 

·
Registered
Joined
·
406 Posts
I take it the car has the 4 cylinder motor?And what year?

P0010 is the intake camshaft actuator....It may be sludged up and not functioning. how often does the car get it's oil changed?
P0449 is the canister vent solenoid circuit. Not easily gotten to as the gas tank needs to come part way down to get to it. Could be bad solenoid, but also a break in one of the wires to it. This is NOT a driveability problem type code.
P0300 is random misfire and probably in concert with the P0010 problem, START THERE. You should be able to remove and clean it pretty easily and try it before buying parts.
Also check your oil level, low oil will affect the variable valve timing system just as much as low oil level will harm the motors bottom end and bearings. If it has been some time since oil AND filter were changed ....DO IT.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks very much. We just bought the car, for cheap thank heavens, and have not changed the oil yet but will do this first. So after that we should be checking wiring and cleaning actuator solenoids, then replacement if there is still a problem correct?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
So an update .... We changed the oil, cleaned the camshaft actuator solenoids, and replaced the camshaft position sensors. Still no power but no engine codes, yet. Previous to this the rpms did not rev up past 2k and car bogged down with acceleration and would not go over 40. No the acceleration is the same except occasional RPM increase up to 3500 without speed increase. And to speed of 30. So I guess next is replacing actuators and then catalytic converter? Any help would be appreciated. The oil was pretty nasty and smelled heavily of gas.
 

·
Registered
Joined
·
406 Posts
Sorry to say, but sounds like a plugged converter on top of what you needed to do. How long have you been pushing this car with it driving so poorly to have fuel contaminated oil???? Sounds to me like the car NEEDS a complete go thru for maint (plugs filters check injectors for dumping [not spraying] fuel)
 

·
Registered
Joined
·
6 Posts
Sounds like the camshaft and exhaust solenoids need to be replaced before you end up having a blown motor with the timing chain breaking with those pieces all over inside of engine. Those engines are crap.
 

·
Registered
Joined
·
3 Posts
Help!?! New owner new to forum. Trying to fix my son's car. Extreme loss of power on acceleration, rpms don't go up, tops out at 40 mph. Throws codes p0010, p0449, p0300. Check engine light and on the way home the brake light and beeping comes on Everytime you push accelerator. Is it cam position sensors or solenoids or cat? Or ? Don't have the money to replace unnecessary parts. Any help would be greatly appreciated
 

·
Registered
Joined
·
3 Posts
Intake n exhaust solenoids 110 4 both 15 minute job my cat can do it
FYI I ve learned this of my g6 she a high maintence girlfriend. I love my g6 I bought a nother just to work on. Expensive yea but worth every cent when ur behind the wheel
 
1 - 9 of 9 Posts
Top