Pontiac G6 Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
The other day while I was driving down the highway my pup decided to hit my shifter into neutral and now my automatic door locks do not work. It does lock by pressing the lock button on the door and on the remote. I have already checked all of the fuses and they appear to be ok. Any thoughts on how to fix this? I really like the feature. Thank you in advance!
 

· GTP 06
Joined
·
588 Posts
check the menu settings on the radio to make sure unlock is set to shift to park. If it is, there is a switch in the shifter to scene when it is in park. That might be screwed up. Does the key less entry unlock the doors?
 

· Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
waterfowler76:
The lock button works right away.

maykevin5:
I will have to check my menu settings. I didn't even think about that because it had worked before. Do you know exactly what menu it may be under? Yes, the keyless entry does work.

Thanks!
 

· Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I had check the menu on my radio and everything was set properly, so I was talking to my dad about it, who is a mechanic, we decided to hook it up to his dyanostic computer to see if it would throw a code. Which it said it was a malfunction in the transmission sensor. We turn the car off and back on and the code cleared itself and everything started working fine. Wish I would have thought of that sooner! Lol. Thanks everyone!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top