Pontiac G6 Forum banner
1 - 20 of 40 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey guys, I've read a lot of discussions here from people with similar problems to what I'm experiencing. Unfortunately, most of them end with people giving suggestions, and never a follow-up or resolution post, so I feel like I'm beating a dead horse on this.
I've got an 07 3.5 V6 G6 with 46k and extended warranty. I've had the rough idle for years, dealer says it's normal. Lately I've noticed something new. Sometimes when driving a consistent speed or with the cruise on, when accelerating slowly or climbing a hill, the car feels like it's hesitating. It's very subtle, but it's there. It almost feels like I got hit by a solid gust of wind for 5 to 10 seconds. I would say it's short of lurching, but if it gets worse, it would be. This only happens when I'm trying to lightly accelerate, if I am trying to pass somebody smoothly or need to punch it, no problems. But if I'm driving 65-72 with the cruise on and have to climb a slight hill, I'll feel it. It's nothing terrible, but it's just enough to make you think twice about it. The wife thought I was crazy, but she noticed it too when driving on the highway tonight.
Has anybody had a similar experience and found a reasonable solution? I know there are lots of possibilities, but I need to go into the dealer with some ammo and knowledge. I just had the car serviced at the dealer 2 weeks ago, the issue existed before that, they said they couldn't find anything, but I'm not sure how hard they tried. I'd love to go in there with a solid idea and not have them take forever trying to solve the problem.
By the way, I'm hoping to drive this car from Chicago to Montana 4 days from now, hence the concern. The car is fully drivable, but I don't want this issue to turn into a problem 1500 miles from home and ruin our vacation. As you can tell from the time stamp, I'm losing a bit of sleep over it. :eek: Thanks guys
 

·
GTP 06
Joined
·
588 Posts
normally the service light will come on if it starts missing or sensor's acting up. I know my cruise control will surge back and forth while topping a hill and descending down the other side, but not up hill. I've heard about this, but I personally haven't noticed a difference. Try resetting your throttle response. Turn Key on, slowly press the pedal to the floor and back up in a 10 second time frame. That is supposed to re calibrate the throttle.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the suggestion, but no luck. It appears I may have another issue as well now. I had a difficult time shifting from park yesterday. Turned off the car, restarted, same thing. When I touch the brake to shift into gear, it makes a sound like the ABS is kicking in. If I just touch the brake, I cannot shift, but if I push the brake in much further than normal, it works. Will be taking the car to the dealer when I return. It would have been nice if the 15,000 mile service I just had done at the dealership would have caught/fixed/avoided this.
Needless to say, this car is not going on vacation with me. Will give an update when I return.
 

·
Registered
Joined
·
2 Posts
Sometimes when driving a consistent speed or with the cruise on, when accelerating slowly or climbing a hill, the car feels like it's hesitating. It's very subtle, but it's there. It almost feels like I got hit by a solid gust of wind for 5 to 10 seconds.
Any news/ideas/solutions for this? It sounds like i have the exact same problem. I have an 07 GTP and it has been really struggling, even with very light acceleration... or uphills. Ive noticed that if you disengage the "tc" button (shut off the traction), its slightly less worse. Im going to schedule an appointment today or tmrw at the dealer - but I'd like to go in there with somekind of idea whats wrong with it...
 

·
Registered
Joined
·
1 Posts
i have had the same problem in the past..turns out the pedal positioning sensor is reading low voltage. had to replace the pedal assembly got from pick a parts yard for 100 dollars where as the dealer wanted 230 dollars. havent had the problem anymore... hope this helps
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Hmm, Seafoam, I just don't trust that stuff. I know people swear by it, but something about it just sounds like trouble waiting to happen.
Will finally be bringing to the dealer this weekend, we'll see what they say. I'm thinking it's a body control module issue. Feeling much better about the extended warranty I purchased.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Follow up on this. Went to the dealer last night, told him what was happening and about the Technical Service Bulletin out there on the Body Control Module. He looked it up, had it taken care of in 30 minutes. Was covered by warranty, but otherwise the charge would have been $31 for labor, so nothing terrible. Too early to tell if it's fixed the acceleration issues, but it's definitely cured the brake lights, shifting and cruise control problem I was having. Hope this helps.
 

·
Registered
Joined
·
9 Posts
G6 hesitation on acceleration

I just rode about 60 miles and found the following. The hesitation almost stops when I have a) turned the traction control off and b) use the manual shift function. That tells me it is something electronic for sure. I was really pissed at first but it sounds like this is something that shouldn't be too expensive. I too have the extended warranty. Because while we try to be good Americans we're not stupid. This car has a number of issues before 50k miles. The rear passenger door lock won't work electronically. The cruise works sometimes, sometimes it doesn't. The rear tire looses air. At least I think it does. Can't complain about that though, that's normal wear and tear. This hesitation thing is making me nuts. I am learning a lot on this site. Like it a lot. Will update when I have something new to report. :mad:
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Definitely take it in to the dealer for a fix. I cannot say for sure that the hesitating is gone, but I haven't noticed it since I got mine fixed. But the cruise not working for you is a definite sign the Body Control Module may not be working correctly. When you start your car, do a quick check to see if your brake lights are on when they shouldn't be, that would explain the lack of cruise and is a BCM issue. Good luck.
 

·
Slick Black Pontiac
Joined
·
151 Posts
I was getting a bit of hesitation and lag from the transmission before I had it serviced (flushed and replaced transmission fluid.) After service no more hesitation. It was due at 60,000 I think but I had it done a bit early.

Since then it has shifted more smoothly too.

Just my 2 cents.
 

·
CSU_trackstar
Joined
·
16 Posts
YO! my car did the SAME thing for about a year, and then my Mass Air Flow sensor went out, cost me about 130 but piece of cake install. It would hesitate up hills just like you said when i set my cruise to 75. Later, the transmission would shift really hard and thats when my check engine light came on.
 

·
Registered
Joined
·
9 Posts
Yes i have an 08 with roughly the same miles and it did not idle rough. It does hesitate on slight acceleration. If I put my foot down real hard it doesn't hesitate. Slight hesitation when I accelerate a little.
 

·
Registered
Joined
·
2 Posts
Took it to the dealer last week and now it runs like brand new again... It says on my invoice that it was an "Internal PCM Malfunction" and that they "Replaced PCM and Program". It was covered by the warranty, so it didnt cost anything.
 

·
Registered
Joined
·
9 Posts
by the way the 08s don't have a body control module .. my problme has yet to be determined. I was told it was spark plug which is definetly possible but they wanted 700 bucks to change the plugs and wire set. Pretty funny! But I am serious I wish I could post the estimate online so other people don;t wast their time like I did.
 
1 - 20 of 40 Posts
Top