Pontiac G6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an 08 G6 and the battery died. Replaced battery with a new one. Now the car starts and only runs for three seconds then shuts off and won't restart until the gas pressure is relieved on the fuel rail. I had the car to an old Pontiac he couldn't solve the problem. Any ideas?
 

·
Registered
Joined
·
3 Posts
I had a similiar problem, drove my 05 g6 down to the store parked it went in looked around back out in less then 20 mins go to start my car and nada nothing she would crank but not start so checked to see if the rail was getting fuel there was some air relieved it car started ran fine lucky just vapor locked then one day while driving through town car sputtered then died wouldnt start back long story short turned out the ground on top of the fuel pump was the culprit. With regular vibration from driving the ground had worked its way up off the turmanel thus not grounding it properly to kick the pump in and allow it to do its thing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks, I'm g s thing fuel,installed,new fuel pump after this problem started. The car starts and runs for about three seconds then stops
 

·
Registered
Joined
·
3 Posts
Thanks, I'm g s thing fuel,installed,new fuel pump after this problem started. The car starts and runs for about three seconds then sto
Thanks, I'm g s thing fuel,installed,new fuel pump after this problem started. The car starts and runs for about three seconds then stops
Got to thinking ive heard of hondas doing that if they changed ECMs with the same numbers. Then when prgrammed to there vin never have the issue again . Did you figure it out yet ?
 
1 - 6 of 6 Posts
Top