Pontiac G6 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I’ve only had this car for about a year. All maintenance kept up properly. I recently had an issue with sluggish acceleration. I stopped by autozone no significant codes popped up, no check engine lights ever, autozone suggested a tune up. (Spark plugs, coil packs, ect) I just picked it back up today from a “tune up” and got new spark plugs, new coil boots, and a new air filter. Still has really sluggish acceleration and a bit of a louder howl or roar when accelerating. Seems to do ok above 30/40 mph, but still feels like a hesitation problem. What could it be? Or where should I start?
 

·
Registered
Joined
·
42 Posts
sounds like your CATALYTIC converter is getting plugged up, it's 13 years old and I'm pretty sure that's the problem. I have an 09 as well ,G6 GT with 160,000 klms and I'm due to get rid of that sucker pretty soon.
 

·
Registered
Joined
·
42 Posts
Thanks for the reply Michael. Would a CAT cleaner be my best bet then in the meantime? Check Engine light just came on yesterday. 😑 Death is near.
I guess it wouldn't hurt to run some type of Fuel line cleaner( a good brand name) and, again, a good brand name octane booster and see if that helps. You might even have some moisture/water in the gas tank, it does accumulate after many years & seasons, dump 2 gas line antifreeze bottles to "dry" up any water in the lines and tank. those are the cheap ways to start, it may help, good luck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Could be bad back pressure from cat or muffler . Shake down auto repair bill for misdiagnosed repair demand money back

thanks
I really didn’t think I had a chance demanding any money back as I did ask for a tuneup. They were pretty rude and charged double than what they quoted me and then the day after I got it back the check engine light came on, and code po420 popped up. I stopped by autozone again to see what code would pop up now that the check engine light did actually come on before going immediately back to the shop, but the guy there at autozone said it wasn’t the shops fault. 🫠 I sure didn’t need the air filter they charged me for though, I checked that myself before I dropped it off.
 

·
Registered
Joined
·
72 Posts
Yes I did Jim! I was told I need to replace one catalytic converter and it is the one closest to the engine.
Does the car accelerate fine if you floor it? I get this code all the time but my cats are not plugged. I believe my issue is the evap system. My car is doing the same the same thing between 1200 - 1700 rpm's under a load. As soon as the transmission kicks down a gear it runs fine. I need to check the evap on the gas tank, the gas pedal switch, the throttle body switch and the coil packs.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
Does the car accelerate fine if you floor it? I get this code all the time but my cats are not plugged. I believe my issue is the evap system. My car is doing the same the same thing between 1200 - 1700 rpm's under a load. As soon as the transmission kicks down a gear it runs fine. I need to check the evap on the gas tank, the gas pedal switch, the throttle body switch and the coil packs.
Its really just that initial acceleration after a stop light that makes it seem like a horse ready to fall on its face. Same as you said though, soon as I get that kick down it does run fine. I can rule out coil packs as an option in improving performance as I just had those replaced. I need to crawl under and take a look and see if there is any significant dents in the cats. I did have my flex pipe replaced last year, the potholes are horrendous on my street it’s not out of the realm of possibility there being a dent in something under there. autozone did initially suggest a throttle position sensor before I got the po420 code. The mechanic did the tune up left me with “The car runs good, you might need a little front end work soon there’s a little bit of rattling” all in one sentence.
 
1 - 11 of 11 Posts
Top