Pontiac G6 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hey guys. I have had this car for about 7 years and it has always had this problem with starting.

About 75% of the time it starts right up.
The other times it cranks but does not turn over unless I give it some gas.
So far it has never left me stranded but Id like to get this sorted out.
One time we called the dealer about it and I was told it was a known issue and its just the way these cars are. I was told to leave the key in the on position for a few seconds before attempting to start it. This works sometimes but I usually still have to give it some gas to start.

Has anyone else had this issue and found a fix? What is the actual cause of this?
 

·
Registered
Joined
·
10 Posts
Hey guys. I have had this car for about 7 years and it has always had this problem with starting.

About 75% of the time it starts right up.
The other times it cranks but does not turn over unless I give it some gas.
So far it has never left me stranded but Id like to get this sorted out.
One time we called the dealer about it and I was told it was a known issue and its just the way these cars are. I was told to leave the key in the on position for a few seconds before attempting to start it. This works sometimes but I usually still have to give it some gas to start.

Has anyone else had this issue and found a fix? What is the actual cause of this?
Mines a 06 G6 GT and does just like yours, mine has 167.000 miles 3.5L I was told it was a small vaccum leak in the upper pendulem.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Mines a 06 G6 GT and does just like yours, mine has 167.000 miles 3.5L I was told it was a small vaccum leak in the upper pendulem.
So you never got it fixed? And do you mean the upper intake manifold?
Mine is actually off the car now and I will be replacing the gaskets so hopefully this fixes the issue for me if thats what it is.
I would be surprised if that was the actual cause of the issue though.
 

·
Registered
Joined
·
6 Posts
Mine has done the same thing since i bought it a year ago - 06 g6 3.5l, When I start it, it turns over but then I need to give it gas or it will stall out. Once it idles it's fine. Sometimes it will do this and sometimes it wont, and once in a blue moon it will not start at all only just keep turning over until I give it a bunch of gas. (It eventually starts on the 2nd or 3rd try of turning the key and pumping gas.)

It really makes no sense to me since nowadays we have fuel injectors. and air leak would probably make sense though. I do sometimes hear an air leaking sound when the hood is opened with the car running.

Best of luck, hope you get it fixed!
 

·
Registered
Joined
·
10 Posts
So you never got it fixed? And do you mean the upper intake manifold?
Mine is actually off the car now and I will be replacing the gaskets so hopefully this fixes the issue for me if thats what it is.
I would be surprised if that was the actual cause of the issue though.
No I havent tried to fix it because it doesnt do it all the time. Yes I was told it was the upper intake manifold and I have had quite a few issues with this car so as long as its running Im not going to try. I bought it almost 2 years ago for 1000.00 had a salvage title. The car runs great but I hate that it doesnt have a transmission dipstick. I know the fluid in mine is really dirty and its only a matter of time for it to go.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
No I havent tried to fix it because it doesnt do it all the time. Yes I was told it was the upper intake manifold and I have had quite a few issues with this car so as long as its running Im not going to try. I bought it almost 2 years ago for 1000.00 had a salvage title. The car runs great but I hate that it doesnt have a transmission dipstick. I know the fluid in mine is really dirty and its only a matter of time for it to go.
Were you told it was specifically the upper intake gaskets that need to be replaced or something else?
I mentioned this in my other thread but when taking apart the engine I did find a hose that goes from the air intake to the rear valve cover could have not been connected at all causing an air leak(I think this is an air hose anyway).
 

·
Registered
Joined
·
10 Posts
Were you told it was specifically the upper intake gaskets that need to be replaced or something else?
I mentioned this in my other thread but when taking apart the engine I did find a hose that goes from the air intake to the rear valve cover could have not been connected at all causing an air leak(I think this is an air hose anyway).
Not specifically but possible.
 
1 - 7 of 7 Posts
Top