Pontiac G6 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi so today I changed the 1-2 shift solenoid in my 2005 g6 6 cyl. Everything went back together good (I think). The old one was fried. So all back together and running good until I went to shift gears. Shifts between gears but wont engage gears...anybody? and all troublecodes are clear now just wont move
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
I can feel and hear the transmission shifting throughout the automatic gearshift. Still no check engine light and running good. Is there something I might have missed putting it back together? Pretty sure I got everything right...somebodys gotta be like House MD
 

·
Registered
Joined
·
441 Posts
May be an obvious question, but is the trans fluid level ok? I have not worked on the G6 transmission, but whilst working on my old Supra I drained a fair bit of fluid during the swap out of a lockup solenoid. Thought I had replaced enough of it but lots got sucked up into the torque converter I guess. Had to keep filling it, start it, cycle through the gears and repeat until the fluid level no longer dropped.

Hope you get it sorted.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for answering Boomer. I rechecked the fluid level but it still doesn't engage any gears. The shift solenoid was a little different than the original. 90 degree difference installed than the original...but the check engine light is off now. Might have to tow it to a shop
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So I haven't been able to get it into a shop yet. I found this online

This problem is common on Chevy 350 turbo transmissions. Inside of the transmissions oil pan there is a valve near the edge of the case that has a S-shaped linkage. This S-shaped linkage can slip off the valve it controls and the transmission will feel like it goes into gear but not move the vehicle.

Anyone know if the G6 has a valve that could have came off while I had the pan off?
 

·
Registered
Joined
·
441 Posts
Looks like you may have spotted your main issue. If something does not look right with the replacement part then it probably isn't right. Electronically it may look the same to the control unit, but if it is not the same size or fits in a different way there is a high probability that it is not having the same effect inside the transmission. I would go with your gut and triple check the part. There are a number of solenoids in a transmission and you can bet that some are subtly different for a reason.

Found this info @ workshop-manuals.com, maybe it will help

Good luck with getting it fixed
 

Attachments

·
Registered
Joined
·
2 Posts
I have a 2007 Pontiac G6 Gt convertible automatic with manual option. Engine is a 3.9 liter V6... last night no problem at all with the transmission, while driving to work the next day in drive, as usual, stops accelerating. Put it in manual, slow catch in first, but drives. Can anyone tell what's going on. How long I can drive like this?
 

·
Registered
Joined
·
1 Posts
I have a 2007 Pontiac G6 Gt convertible automatic with manual option. Engine is a 3.9 liter V6... last night no problem at all with the transmission, while driving to work the next day in drive, as usual, stops accelerating. Put it in manual, slow catch in first, but drives. Can anyone tell what's going on. How long I can drive like this?

Hey Wala,
I have a 2006 G6 GTP same engine and same Transmission. I have the same problem as you but still haven't found a solution. Mine cannot longer be drive as i cannot get the car to accelerate. I can reverse just fine but unless its downhill the car is not able to accelerate from rest. Did you have any luck with it?
 

·
Registered
Joined
·
2 Posts
My girl friend had overfilled the transmission fluid and now the car will not shift have to use manual. I draind the transmission fluid to proper level and still the car will not shift using automatic drive. I have to use manual to shift the car. When I use the drive the car will just rev up and the car won't move but when I put it in manual the car shifts fine. Any advice please.
 
1 - 10 of 10 Posts
Top