Pontiac G6 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello All,

I have a friend with a 2006 G6 with the V6. My friend seems to have a occasional starting issue. Sometimes the car cranks 2-3 times before it starts. The problem seems to occur maybe once a week. I searched and came up with a lot of similar issues. I noticed some people had the pcm reprogrammed but the problem was just reduced and another tried the fuel pressure sensor but did not post back with an update. I was wondering if GM had figured out what the fix was?



Thanks in advance:)
 

·
Registered
Joined
·
1 Posts
I have a 2006 G6 and I brought it brand new off the lot. I have had it for almost 3 yrs now and I have been having the starting problem for about 2 yrs. It does not have the starting problem every time I try to start it but it does happen VERY Often! I just moved to Georgia and had to get an Emission Test done and it failed because the car didnt start and the tech tried 3 x's. I got in and started it right away because I know that if I put my foot on the gas, it will stay running....I really need to get this problem fixed but cannot afford to spend unecessary money on things that wont fix the problem. I have to pass the Emission in order to enroll my son in school...So if anyone knows what the problem is, PLEASE HELP!
 

·
Registered
Joined
·
606 Posts
My 04 Malibu 3.5 V6 has done that since new, dealer could never fix. Mine did it when engine was half hot, like mid way between normal.
Traded for a G6 2.4 4 cyl, starts great.
 

·
Registered
Joined
·
3 Posts
I've found what I believe to be a permanent solution to this problem. I cleaned out the throttle body with choke spray about 6 weeks ago and my wife says the problem is gone. It was full of oil and gunk. Not a single issue since the cleaning. 5 minute fix. Hope this works for everyone else.
 

·
Registered
Joined
·
14 Posts
I've found what I believe to be a permanent solution to this problem. I cleaned out the throttle body with choke spray about 6 weeks ago and my wife says the problem is gone. It was full of oil and gunk. Not a single issue since the cleaning. 5 minute fix. Hope this works for everyone else.
I get this problem randomly when the engine has just been run to full temp and allowed to cool off slightly. I'll have to try this, thanks. It's not quite a huge issue, just scares you for a second, haha.
 

·
Lifetime Member
Joined
·
3,269 Posts
I've found what I believe to be a permanent solution to this problem. I cleaned out the throttle body with choke spray about 6 weeks ago and my wife says the problem is gone. It was full of oil and gunk. Not a single issue since the cleaning. 5 minute fix. Hope this works for everyone else.
I get this problem randomly when the engine has just been run to full temp and allowed to cool off slightly. I'll have to try this, thanks. It's not quite a huge issue, just scares you for a second, haha.
What do your cars have in common? I find it hard to believe that the G6 simply has a defect that allows enough dirt and grime to build up enough to cause this. Are there some common denominators here are just a freak event in these few cars?:confused:
 

·
Registered
Joined
·
14 Posts
I'm from upstate NY, cold winters, lots of snow, um '05 G6 GT, that's about it? I doubt weather would cause this. Everything engine operation wise is stock until today with a new air filter. This isn't a huge problem and only happens usually like once a month for me. I actually had my fuel injectors replaced by a dealer for fixing this exact problem. It helped somewhat in reducing the frequency it happens, but that's about it.
 

·
Live Free or Die
Joined
·
13 Posts
I am not sure if my issue falls in this category or not, but every so often (more noticeable in the winter, but sometimes in the summer) when I go to start my car, it hesitates and doesn't start. Sometimes it is a long start process as if I am holding the key in the start position for way too long. Most of the time the car doesn't start and I have to try again and sometimes it takes as many as 3 attempts before it starts. This also happens when I use the factory remote start. Twice now in the winter time, I remote started it and the engine/starter stayed in "held key down for too long" phase and it stays like that for at least 30 seconds. I may try what nmcqueen469 said earlier to see if that fixes the problem. Just thought I would get my comment out there!
 

·
Registered
Joined
·
1 Posts
Wasup guys... I recently test drove a 05 G6 GT w/105000 mi on it. It drove fine the first time I took it up. However, when I went to start it back up after it sat for a few minutes, it would start and then stall. The dealer didn't know what to do. Is this a fixable problem and should I still buy if this problem is pre-existing?? Also, how many other problems should I be weary of?

Thanks a lot!

Rho
 

·
Registered
Joined
·
3 Posts
What do your cars have in common? I find it hard to believe that the G6 simply has a defect that allows enough dirt and grime to build up enough to cause this. Are there some common denominators here are just a freak event in these few cars?:confused:
Wife's car has a K&N air filter, that's it. Maybe a sealing issue letting dirt by that accumulates in the throttle body?

The dirt/oil makes the throttle body blade stick closed, which causes the starting issue. No air=no start.

Beats me, but this is an easy fix.
 

·
Lifetime Member
Joined
·
3,269 Posts
Wasup guys... I recently test drove a 05 G6 GT w/105000 mi on it. It drove fine the first time I took it up. However, when I went to start it back up after it sat for a few minutes, it would start and then stall. The dealer didn't know what to do. Is this a fixable problem and should I still buy if this problem is pre-existing?? Also, how many other problems should I be weary of?

Thanks a lot!

Rho
Well if it were me I'd say no to the purchase. An "05" with 105K miles isn't over board but it isn't even yours and its already given you trouble. If you have an honest mechanic (which I recommend we all do) let them look it over. There are deals to be had so my advise would be to scrap that one and look around. If a G6 is the car you want you can try searching car forums. Hope to see you back here with a G6.

Wife's car has a K&N air filter, that's it. Maybe a sealing issue letting dirt by that accumulates in the throttle body?

The dirt/oil makes the throttle body blade stick closed, which causes the starting issue. No air=no start.

Beats me, but this is an easy fix.
Glad its an easy fix for you. I'm not a fan of K&N but most peeps here are.
 

·
2006 Black G6 GT
Joined
·
395 Posts
Okay well i have had this problem in both my old 1997 T/a, and my moms 01 cavalier.
In both cases after about 2 years of the exact same problem our fuel pumps went out. Once we replaced them we never had the problem again.

So i think that once this starts, its an indication your fuel puump is starting to go.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top