Pontiac G6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So recently i’ve been offered a free 2008 G6 with the ecotec if I could get it working. From my limited testing and knowledge, I cannot even begin to think what’s wrong.

What i’ve seen so far electronics issues such as the back locks not being actuated by the front lock switches or the fob not working. The main issue currently is just having it run normally which it doesn’t. It can idle just fine but if you give it gas it can only make it to 3k. Even full pedal goes right up to 3 then slowly stumbles down and down in the rpm range. When it’s stumbling the dash icons will light up as if it stalled but then it goes right back to normal, repeating this a bunch whiles it’s stumbling down the rev range. No CEL is on, the only error displayed is to check the airbag.

I was told the previous owner took it to a mechanic who couldn’t solve the low power issue (I haven’t drove it yet but ai don’t see how that could change in a week). The mechanic apparently said to take it to the dealer…

I haven’t been able to code scan it so tomorrow I’ll scan it just to double check and post if I get anything. Just want to see if anyone has input… Would love to own this car but if the issue are expensive and exhaustive I’ll have to pass :(.

sorry for the paragraphes!! hoping to get some advice or some links of suggestions to try
 

·
Registered
Joined
·
843 Posts
Some weird electrical issues have been caused by bad grounds. There are a number of threads on this site where the grounds have rotted internally. If you have jumper cables available you could try attaching them to the battery ground, engine and chassis ground points.

Another item to check is the BCM. Corrosion and poor connectivity can cause odd body related issues like brake lights, cruise control, instrument cluster oddities. The door locks would also be controlled here as well. If it is not related to the main grounds, adding dielectric grease to the two removable connectors and working it in is effectively what the GM recall did to address some BCM related issues.

Hope you get it working.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Some weird electrical issues have been caused by bad grounds. There are a number of threads on this site where the grounds have rotted internally. If you have jumper cables available you could try attaching them to the battery ground, engine and chassis ground points.

Another item to check is the BCM. Corrosion and poor connectivity can cause odd body related issues like brake lights, cruise control, instrument cluster oddities. The door locks would also be controlled here as well. If it is not related to the main grounds, adding dielectric grease to the two removable connectors and working it in is effectively what the GM recall did to address some BCM related issues.

Hope you get it working.
Thanks for the ideas!! It’s terrible weather outside right now so tomorrow I’ll check the issues you listed and see if I can find something. I actually drove the car back to my house and have some more info.

So the whole drive home it would not go past 20 (in kms) so it was painfully slow. Fully depressing the pedal would only make it go slowly and start to bog + make the dash flash like I described above. Once home, I got out and smelt a burning sort of smell from somewhere upfront on the drivers side of the engine bay. Couldn’t figure out what it was though:(

For some odd reason once I got home I could rev it like normal, definitely had an odd amount of white smoke coming out the tailpipe but both the coolant and oil are both clean which makes me think it’s not a head gasket…Battery keeps going flat though so I’ll have to toss a spare on it and see how it behaves.

Sorry for the massive post, just getting frustrated lol. I really appreciate the help.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Disregard my above message :) Going to part it out, head is blown and the condition of the car it’s not worth fixing and cleaning. Thank you for the help, will make a new thread about parts!
 
1 - 4 of 4 Posts
Top