Pontiac G6 Forum banner

1 - 12 of 12 Posts

·
2008 G6
Joined
·
8 Posts
Discussion Starter #1
my pontiac g6 3.5L automatic does not shift right. it was fine the day before and now when im driving it has no power and the RPM goes way up and i can only go 50km/h. when i let off the the gas it shifts but as soon i put my foot on the gas it is guttless and the same thing happens. there is no warning lights on my dash. does this mean i need a new transmission? has anyone else has this problem?
 

·
Registered
Joined
·
59 Posts
had that same problem with my last car, needed a new transmission, said "**** thaatttt", and now im here.
 

·
Registered
Joined
·
2,388 Posts
my pontiac g6 3.5L automatic does not shift right. it was fine the day before and now when im driving it has no power and the RPM goes way up and i can only go 50km/h. when i let off the the gas it shifts but as soon i put my foot on the gas it is gutless and the same thing happens. there is no warning lights on my dash. does this mean i need a new transmission? has anyone else has this problem?
'08 G6 3.5l

The powertrain warranty is for 5yr/100K miles so I hope you are still covered. If you are not, you start by getting the tranny codes read by someone with a capable scan tool (not autozone).
 

·
2008 G6
Joined
·
8 Posts
Discussion Starter #4
im passed 100km... will the scan tool still work even though there is no warning light on my dash? it was shifting great the day before and now after i changed my belt it doesnt shift. shouldnt you be able to notice that the transmission is going for a period of time or can it just all the sudden quit?
 

·
Registered
Joined
·
2,388 Posts
im passed 100km... will the scan tool still work even though there is no warning light on my dash? it was shifting great the day before and now after i changed my belt it doesnt shift. shouldnt you be able to notice that the transmission is going for a period of time or can it just all the sudden quit?
That's 100,000 miles.

Most tranny codes don't turn on any dash warning lamps.

If you just did some work on the vehicle obviously that could be involved.

Trannys often fail without warning.
 

·
Registered
Joined
·
25 Posts
I've heard the throttle body can actually be the cause of a problem similar to this. You might want to look into that
 

·
2008 G6
Joined
·
8 Posts
Discussion Starter #7
i have 180 000km and thats over 100 000 miles... and now my engine light just came on :( . tomorrow i will take it in to see whats wrong with it. i just hope its not something expensive...
 

·
2008 G6
Joined
·
8 Posts
Discussion Starter #8 (Edited)
i will definently try look into the throttle body or maybe i knocked a sensor when changing the belt. i will let you know whats wrong with it though
Update: i checked the throddle body and there is oily crap in there. is that suppose to be?
 

·
Registered
Joined
·
2,388 Posts
i have 180 000km and thats over 100 000 miles... and now my engine light just came on :( . tomorrow i will take it in to see whats wrong with it. i just hope its not something expensive...
If the CEL came on you quite likely have a code that autozone's code readers can read. You might start there. I'd need the exact code number.
 

·
Registered
Joined
·
2,388 Posts
Update: i checked the throttle body and there is oily crap in there. is that suppose to be?
No. It should be clean. But at over 100,000 miles of operation & possibly having never been cleaned, a certain amount of oily/sludgy buildup would be expected. Spray in some throttle body cleaner & wipe it out with a shop rag. Be careful not to damage the interior finish.
 
1 - 12 of 12 Posts
Top