Pontiac G6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
The ac compressor does not engage. Bypassed the ac control relay pins 30 & 87 and the clutch engaged. The ac blows ice cold with the clutch engaged. Measured voltage on the ac high pressure switch with 4.9v on supply and 3.85 on the signal. Verified ground with continuity check. I cannot visually locate the ac low pressure switch. Where is it? Can you share where this is located so I can check it? Thanks.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
From what I am reading there is a single pressure switch

View attachment 19200
Thanks for the reply. So if I understand your reply, there is only one AC pressure sensor on the 2009 2.4L G6 AC system which is the high pressure sensor. The engine off (static or quiescent) voltage from the high pressure ac sensor is 3.85 vdc. I did not measure the signal voltage with the compressor clutch jumped out and engine on. To get all the data points I will check it. With the clutch engaged (solenoid jumped out), the front cooling fans appear to cycle correctly. The AC blows ice cold with the clutch engaged. I used a basic (cheap with few diagnostic features) ODBII meter to check for error codes and did not see any AC codes. I cleared all codes and will see what codes return. Currently, tire sensor codes are the only ones tripping. If there is only one AC pressure sensor, perhaps it is not working correctly? Measuring the engine on/AC on voltage will show if the signal voltage is changing with the engine on. Hopefully it is not changing voltage and the issue. I will post what I find. Thanks!
 
1 - 3 of 3 Posts
Top