Pontiac G6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone. My name is Nate Hansen. I live in gentry AR. So I have a mystery g6. I bought it in May. Ran awesome until 2 months ago. Mechanic said fuel pump went out. Ok ya know fine. Ever since it will run for 5-7 days then all of a sudden won't start. It turns over but that's it. Now the next day it fires right up. So folks it's gotten so unreliable that I had to go and put 600 down on a minivan lol. But ya know what at least it's starting. I absolutely do not understand. When I would send it back to my mechanic it would start every dang time. Please someone help. It's a awesome car when it starts.
 

·
Registered
Joined
·
144 Posts
Why not

Listen to your mechanic? I just went through a fuel pump fix. I could have sworn it was not the fuel pump but in the end it was. My retired father in law and my brother-in-law both mechanics by trade said fuel pump. Took it to gm garage. After swallowing my pride, it runs perfect so far.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Ok. Well maybe I worded it wrong. He did change the pump. That's the problem. 327 dollars worth of fuel pump. But ever since its been driving us crazy. Thursday and Friday would not start. Saturday evening it just fired right on up. Can the tumbler or ignition switch or chip key have anything to do with it I wonder??.
 

·
Registered
Joined
·
74 Posts
Re Read post # 2, very easy to overlook the harness plug connection to the fuel pump. My brother in law had similar with a GM SUV, was a bad harness connector to the pump. Fuel tank had to come out a second time to fix the problem. Come to find out that it was a common problem for those SUV's.
 

·
Registered
Joined
·
144 Posts
Ok thanks Nate. If it cranks and does not start, have you check to see if it has spark or not? Is it getting fuel or not. If you have the answer to these questions, that should help lead you in the right direction. If you have one without the other, try to target the one you don't have. Rebel and Zenish may be on target. How about ground wire. A poor ground can cause a lot problems. Have you got a good battery? I had a battery that showed 12.7 volts but that was not good enough to start my cars. Scotty Kilmer has a good video on this. You really have only given us a bit of information. Maybe that is all you have.
 
1 - 6 of 6 Posts
Top