Pontiac G6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,
I am having an issue with my G6. While driving or idling my gauages will for a quick second go all the way up then zero then back to normal.
When this happens all my dash lights will come on. Sometimes the radio will go out for this second and my A/C will go out the first time this happens and not work again.
This problem is very irregular. Itll happen about every 30 seconds to a minute. It being in the middle of summer I would like to have my AC working.
Any advice would help. I took it to a shop they suggested a bad ground
Something about looking up a diagram for the grounding points and checking them but google yielded nothing.
 

·
Registered
Joined
·
604 Posts
It does sound like you are losing power (or ground) somewhere. I am thinking that the gauges, radio and AC have some common connectivity to the body control module. You will find it and the connectors by the passenger foot well fuse box. I would remove the two big connectors and add dielectric grease (push it into the pin holes on the socket). Carefully insert and remove a few times to get it all seated well. Make sure you clip it back in securely once you are done. I would also make sure the fuses are seated properly and any of the power and ground connectors in that area are tightened down and the wires are in good shape.

Hope you find and fix it.
 

·
Registered
Joined
·
10 Posts
Sounds like your cluster is losing power and doing a restart needle sweep. Pull the lower dash panels off and do a GENTLE harness wiggle test while the ignition is on and see if you can replicate the problem. Yanking on the harness may make the problem go away temporarily or pull pins out of a connector and do damage . Just lightly push with a finger on everything electrical.
 
1 - 3 of 3 Posts
Top