Pontiac G6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just purchased my 2010 g6 a week ago the very next day the car wouldn’t crank turns over just fine but won’t crank . So we replace the battery terminals as they were worn and the car runs fine until the next day and i drive it about 10 miles and go back to crank it and it seems to be not getting power or something i could hear it dying down. Pushed the gas pedal and nothing then it just died down and wouldn’t crank again . Had to leave the car when i came back the next day it crank right up . There are no lights on the dash . And it has 160000 miles. I’m stumped and so are the men in my family who i usually go to for help anyone who can point me in the Correct direction would be so very appreciated . Tia
 

·
Registered
Joined
·
17 Posts
Have it scanned anyway. Codes could have been cleared previously, and my take a bit to re-register and show up.
 

·
Registered
Joined
·
5 Posts
I just purchased my 2010 g6 a week ago the very next day the car wouldn’t crank turns over just fine but won’t crank . So we replace the battery terminals as they were worn and the car runs fine until the next day and i drive it about 10 miles and go back to crank it and it seems to be not getting power or something i could hear it dying down. Pushed the gas pedal and nothing then it just died down and wouldn’t crank again . Had to leave the car when i came back the next day it crank right up . There are no lights on the dash . And it has 160000 miles. I’m stumped and so are the men in my family who i usually go to for help anyone who can point me in the Correct direction would be so very appreciated . Tia
Check all grounds .sounds like fuel pump
 
1 - 4 of 4 Posts
Top