Pontiac G6 Forum banner

1 - 20 of 62 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
I own a 6 speed GTP Coupe. Shifting too second and third gears (and some times to 6th) is very stiff. I even feel the ' GEARS ' in the shifter. Dealer ajusted a cable for the 6th and it partly fix this gear but it still hard to get it in gear if the engine is HOT. I was wandering if this is a problem with other GTP's 6 speed G6 by Pontiac ???

Oh ya! Every time I shut the engine off, there is a loud CLIK coming from the front of the engine. At the beginning it's cliking fast and after a few second the cliking is less faster, but it will click for at least 5 minutes.... I wander if there is a relation ????

For the rest this car is great ! But Who decided to put the third brake light is the rear window ?%?%?%?% Can't see what's happening behind the car ! !! ! ! !
 

·
Registered
Joined
·
268 Posts
vette79 said:
I own a 6 speed GTP Coupe. Shifting too second and third gears (and some times to 6th) is very stiff. I even feel the ' GEARS ' in the shifter. Dealer ajusted a cable for the 6th and it partly fix this gear but it still hard to get it in gear if the engine is HOT. I was wandering if this is a problem with other GTP's 6 speed G6 by Pontiac ???

Oh ya! Every time I shut the engine off, there is a loud CLIK coming from the front of the engine. At the beginning it's cliking fast and after a few second the cliking is less faster, but it will click for at least 5 minutes.... I wander if there is a relation ????

For the rest this car is great ! But Who decided to put the third brake light is the rear window ?%?%?%?% Can't see what's happening behind the car ! !! ! ! !
The clicking is the heat shields cooling down, its normal especially on new cars. I also have the problem with second and third, sometimes it even grinds, it sound to be just and adjustment issue. A buddy of mine is a GM tech and he has had to adjust 2 or 3 of them so far.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #3
Follow up....

Went to the dealer today. The only thing the mechanic could do is to do some bending of the linkage between the shifter and the transmission using a very large screw driver. Just like we where doing on those old Camaro and Vettes in the early 70's, I don't find this has a solution because after a few miles I still can feel the GEARS rolling into the shifter on 2nd and 3rd, which I don't feel in 4,5,6.

Next step will be to test drive an other GTP 6 speed at a dealer and compare the feeling by myself.

GM mechanics don't have any specs for ajusting this new transmission.... They are learning upon every case they get, but since 6 speed are scarse, they really don't know how to ajust or fix this tranny...

Will keep posted a the next step....
 

·
Registered
Joined
·
268 Posts
vette79 said:
Went to the dealer today. The only thing the mechanic could do is to do some bending of the linkage between the shifter and the transmission using a very large screw driver. Just like we where doing on those old Camaro and Vettes in the early 70's, I don't find this has a solution because after a few miles I still can feel the GEARS rolling into the shifter on 2nd and 3rd, which I don't feel in 4,5,6.

Next step will be to test drive an other GTP 6 speed at a dealer and compare the feeling by myself.

GM mechanics don't have any specs for ajusting this new transmission.... They are learning upon every case they get, but since 6 speed are scarse, they really don't know how to ajust or fix this tranny...

Will keep posted a the next step....
Mine was in today, the couldent reproduce the problem. but for some reason its doing it alot less now.

Edit, It dosnt do it at all anymore.

So as I said the "Couldn’t reproduce the problem" Well well well, I had a look at my linkage and it was slightly bent! They knew exactly what was wrong and fixed it, but refused to admit to it! lol
 

·
Registered
Joined
·
113 Posts
Discussion Starter #5
Cold weather

After they palyed priying the linkage bracket, the cold weather came in. It was 25 degrees in Montreal Canada. I could'nt even shift from 1st to 3dr... Priying a braket don't seem to be the solution, so I will get the car back to the dealer and this time priying a braket won't be accepted as a solution...
 

·
Registered
Joined
·
113 Posts
Discussion Starter #6
Got the car to the dealer. They kept it overnight to test the shifter when very cold. Finaly they will replace the shifter cable(s) and it should (I hope) fix the problem. The cable has been ordered, I will get it replaced sometime next week. Will keep you informed.
 

·
Registered
Joined
·
58 Posts
Vette79, I have the same problem when it's cold out. I can't shift it back into 1st, unless I'm at a dead stop. If I run it through the gears at a stop light, that seems to loosen or warm it up quicker. I need to take it to the dealer, but I was waiting for cold weather to set in, so they would be able to reproduce the problem. Please let me know what your dealer ends up doing for you.
 

·
Registered
Joined
·
58 Posts
Vita said:
doesn't it use the F40, as in the 6 spd. from the 9-3?

it's not like this is a brand new tranny...
I'm not sure I understand your point? It's not new, but we're having a problem, and if we can't recreate it, they can't fix it.
 

·
Registered
Joined
·
114 Posts
Weller said:
I'm not sure I understand your point? It's not new, but we're having a problem, and if we can't recreate it, they can't fix it.
my point is that it's not a new tranny, and you shouldn't be having any issues. i'll take a wild guess and say that if they do re-create it, it'll be considered "normal"

if not, they'll likely tell you you're not pushing the clutch to the ground between shifts, since they can't duplicate (could be the issue...).

another reason i mention that is you might want to see if the 9-3 has the same issue.

so in my eyes it's either an adjustment in the linkage that needs to be made, or the clutch is getting let out before completely in gear...
 

·
Registered
Joined
·
58 Posts
Vita said:
my point is that it's not a new tranny, and you shouldn't be having any issues. i'll take a wild guess and say that if they do re-create it, it'll be considered "normal"

if not, they'll likely tell you you're not pushing the clutch to the ground between shifts, since they can't duplicate (could be the issue...).

another reason i mention that is you might want to see if the 9-3 has the same issue.

so in my eyes it's either an adjustment in the linkage that needs to be made, or the clutch is getting let out before completely in gear...
I don't think I have an issue with the tranny, I believe the problem is in the gearbox. It may work fine in the 9-3, but that doesn't mean everything lines up perfectly in the G6. I would hope they don't consider something that works fine in warm temperatures, but has issues in cold temperatures, to be "normal". I'm sure they would tell me I'm not pushing the clutch in far enough, which is why I've been waiting for cold temperatures before demonstrating the problem. It's likely just a simple fix with the cable, which is why I was asking Vette if his problem was solved.
 

·
Registered
Joined
·
114 Posts
good luck with it either way. could be something simple like a tension spring as well.

i just hope for all your sakes that they don't have to rip up the tranny to fix it, i've yet to get a recall done on my car because of that (though i'm not sure i really notice the issue...)
 

·
Registered
Joined
·
113 Posts
Discussion Starter #15
The part has not yet arrived...... Xmass time?????
But the problem is still on, either cold or warm. It gets worst when I start very cold, the dealer found the same problem. I don't know if a cable change will fix the problem since I feel that the 2nd and 3dr gears doesn't seem to line up well, I am awaiting for the part and then I will see. By the way. I do press the clutch way down to the carpet, still have the same problem... Will keep you posted.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #16
Got the car to the dealer january 18th. They changed the shifter cabels which is quite a big piece that took nearly 6 hours to replace.

Now the shifter is much smoother to handle, but the gringe is still present on 2nd, 3rd grears. So part of the problem is settled, but not all of it.

The mechanic admits that there is some abnormal friction on those gears, 4,5,6 are as natural as any other tranny on other cars. But second and third are'nt. Next step is to test drive the car for a few days, and if it's still the same they will have some DSM (District Service Manager ???) test the car for a decision. I though BLACKRIDER on this site did get a transmission change for the same problem, but actually they changed the shifter cable also, but the tranny seems not to have been changed ??? and he still has the 2nd, 3dr gears friction problem.

So if any of you had the problem solved, please advise me on my mail since a dealer name and a workshop information would help a lot. Will keep you posted.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #18
Don't know what is wrong but I am not going to accept this situation for a car that I paid 33 500$ (CDN) + taxes + interests to GMAC. Next step will be to compare with an other car so to confirm that I'ts not a normal thing. My feeling is that there is some problems with some synchronisation parts for those 2 gears, if it where a fluid problemm I would expect to have the problem on all gears!

We will see.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #19
More news. BLACKRIDER got in touch with me today and he actualy did get a tranny change but it's not 100% correct eventhough.

I asked him for more details so my dealer can verify with his dealer and get some action done,

This is a good example of the information and help we can get with this type of internet site. Hopefully with G6OC club it might make my life easier.

Thanks G6OC.
 

·
Registered
Joined
·
14 Posts
Thus far our car has been problem free for the transmission. No issues with it at all.

There are no service bulletins, prelim info or any other tech articles at all on the 6spd grinding issues that you and Jordie are experiencing. IF and When GM puts something out for a possible fix, You guys will be the first to know what the correction for the issue is.
 
1 - 20 of 62 Posts
Top