Pontiac G6 Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Can anyone give me an idea on why my abs, traction control,and brake light all come on when I apply break? I just had brand new front and back calipers,rear rotors, and front brake hoses. I'm wondering if something didn't get bumped knocked or what happened. Anyone have any input would be appreciated very much. By the way it's a 2009 g6 gt
 

· Registered
Joined
·
1 Posts
Frustrating, isn't it? My '08, purchased in '13, has had a similar issue since I got it. Sometimes, when coming to a stop, the traction control and the stability control lights come on and stay on. The radio alerts me that I need to service the stability and traction control. I learned to ignore it! I park the car, go to work, and later start the car to head home. The same lights come back on. After a minute or two, they go out. Until the NEXT time, usually a few days or so.

My mechanic says I have a gremlin in the electronics. You can try to reset the electronic control module, the "brains" of the electronics. I do this every year or so, when shit really starts acting up.

Turn off the engine. Turn on the headlights, the wipers, the radio, the fan, everything electronic. Disconnect the positive and negative battery cables from the battery. Now, CONNECT the positive and negative cables TOGETHER.

Walk away for a couple of hours. This will allow the internal electronics in the car completely discharge to nothing.

Turn off everything you had turned on, reconnect the cables to the battery terminals, and start the car.
Think of it as rebooting your computer when it starts acting up.
 
1 - 2 of 2 Posts
Top