Pontiac G6 Forum banner

1 - 20 of 22 Posts
Joined
·
205 Posts
Discussion Starter #1
Does anyone experience extreme acceleration lag with their G6 while the a/c is on? I noticed it this summer when I used my a/c a bit more.


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
4,232 Posts
Which engine do you have? I have the 4 cyl and you can notice the lag from the a/c while trying to accelerate
 
Joined
·
205 Posts
Discussion Starter #3
Yes I have the 4-cyl. It's really bad. I have to put the pedal completely down if I want to accelerate at a decent amount. Is there anything we can do?


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
4,232 Posts
Although I experience some lag I don't feel I need to put the pedal all the way down to accelerate a decent amount. There's lag but it's not robbing all of my power, just some.

But then again I have a Cold Air Intake and a WAMS tune which gave me a little more power. Maybe it's enough to not notice the A/C as much? When it was all stock I don't remember the lag being that bad...

Does it seem like there is an abnormal amount of noise from your a/c? Mine would sound like a diesel whenever I was idling in gear with the A/C on. Turned out to be a loose compressor, low on refrigerant, and an abnormally worn belt...
 

·
Registered
Joined
·
2,388 Posts
Yes I have the 4-cyl. It's really bad. I have to put the pedal completely down if I want to accelerate at a decent amount. Is there anything we can do?
What's the mileage on that 2.4l?

Are you sure you have normal acceleration at A/C off?

When did you first notice this?

Did it happen suddenly or get progressively worse over time?

No warning lamps on?

Still on the original cat convertor?
 
Joined
·
205 Posts
Discussion Starter #6
Ya when I park my car with the a/c on and get out it sounds kind of loud. No my acceleration is normal without the a/c on. When it's on it's considerably worse my car only has 54,000 miles. Nothing has been replaced on it except the power steering. I noticed the lag a week or two ago. No lamps on.


Sent from my Autoguide iPhone app
 
Joined
·
205 Posts
Discussion Starter #10
When your a/c is on and you step outside the car, is It quiet? Maybe the level of sound from my a/c is normal idk. But i do know its Robbing me of a lot of power when it's on.


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
4,232 Posts
Are you able to maybe have someone sit with a camera recording the compressor while you turn it on and off and such. In fact, I'll shoot a vid of how mine is running at idle so you can compare..

I have also turned off the A/C when I know I need to accelerate with some force, And then I'd just kick it back on when I'm near or at speed

also what part of Chicago are you in (sorry of I asked before. haha)
 
Joined
·
205 Posts
Discussion Starter #12
Haha that's what I began to do. Turning it off when I need to accelerate a good amount, ya the video would b great. I'm near oak lawn If you know where that's at.


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
4,232 Posts
Yea I do actually, I used to have to drive past oak lawn a lot. I was actually in bridgeview recently for a car show.

I shot some videos and came across one alarming thing. On a cold start, even with the A/C off, the engine starts with the compressor engaged. Which explains a noise I've been curious about since I bought it.

But that's another situation.

Here's the vid of the car idling and revving with A/C on and off.

It may be hard to hear because of all the engine noise but maybe it can give some insight?


Also I'm up near Gurnee, about a half hour west from 6 flags...

I was thinking of doing a quick drive with the cam on my gauges or something, But having the intake and tune would throw it off when comparing to your car.
 
Joined
·
205 Posts
Discussion Starter #14
Yes I've posted about that weird noise from a cold start. You talking about the rattling noise that lasts about 2 seconds? That's cool you're not that far away. I'll look at the videos


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
4,232 Posts
I heard that rattle at start up could be the valves bouncing off the pistons. I don't have a rattle, It's just a solid knock right after start up, Not every time. Usually on a cold start after it's been off for quite a while...
 

·
Premium Member
Joined
·
4,232 Posts
My G6 is a 2009 and therefor shouldn't have a steering problem. And I haven't really...

You can hear it in the first video I posted. When you go to start the engine it'll start up normally, but the second it's running there seems to be a knock. I always thought it was the engine shifting on the mounts or something. It wouldn't sound like a click or anything (which is another sound I get but that's related to driving it and such...)
 

·
Premium Member
Joined
·
4,232 Posts
Tomorrow I'll set up my phone the same way as that second video for a much better shot, see if I can get a better look of it happening. Glad I finally found out that noise, got one more to figure out really. haha
 
1 - 20 of 22 Posts
Top