Pontiac G6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Sorry if this question was asked already, searched everywhere but cant seem to find an answer.

I have a 06 pontiac g6 gt with monsoon system, A while ago i purchased 2 kicker subs 12in & a Kenwood kdc-x794 head unit. I tried installing the head unit myself but no sound came out of the speakers once i was done, so i said f*** it & just took it to the audio shop. I was in the military at the time & was stationed in the middle of nowhere so i had to go with only ghetto ass audio shop in the area. once i got there the guy said something about the head unit needed an adapter of some sort for the stock monsoon amp, so instead he said he installed the stock speakers to the built in amp in the head unit.

At the time i was kicking my self for not getting a big amp the could support my 2 subs & speakers, but everything sounded fine so i went with it.

The problem starts here, every time i bump my music loud with bass and all that my speakers fade out & all you hear is bass. it seems to happen especially when there's alot of bass in a song. I have to turn the music down or off or pause it wait a couple minutes, turn it back on & its fine again, a while later it does it all over again. My subs are good though separate amp & everything. Im sure the problem lies somewhere with the speakers being hooked up to the built in amp. as man y people who have aftermarket stereos i can never find a similar problem.

I got stationed somewhere else so going back to that audio shop is out of the question, not that i would go back to him anyway. does anyone know whats wrong & how the hell to fix it. I will eventually be purchasing new speakers & a separate amp for them, but in the mean time id like to know whats going on with it.

Thank you in advance
 

·
Registered
Joined
·
1,420 Posts
This may not be what's wrong, but your stock monsoon speakers are 2ohm speakers. Most HU amps are made for use with 4ohm speakers. Your specific HU is rated for use with 4-8ohm speakers. Like I said, this may or may not be what is going on, but prolonged use of those speakers on that HU will burn out the internal amp. If I were you, I'd either put new speakers in now before you completely ruin in internal amp, or have the stock speakers hooked up back through the monsoon amp.
 

·
Registered
Joined
·
121 Posts
Mine does this too. I'm thinking it's from my amp getting really hot. (It's winter now and hasn't done it once.) My speakers are blasting and my subs are pounding then BOOM, no sound. Just bass.

Check to see if your amp is overheating.
 
1 - 4 of 4 Posts
Top