Pontiac G6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,

Been having problems with this, I wanted to check here to see if anyone has any clue what is happening with my air conditioner.

I have a 2005 Pontiac G6 and my air conditioner only works on the highest setting (4). For a while, it was only working on 2-4 and now it's just 4. I get no reaction at all on the first 3 levels so it's either the highest setting or nothing. The AC works really well on the high setting so I'm not sure if there's a problem with the unit itself or if there's an underlying electrical problem.

Thanks in advance!
 

·
Premium Member
Joined
·
4,232 Posts
Now by the AC working only on 4. Do you mean, the blower will only blow air on 4? Or will it blow air on all settings, but only setting 4 blows cold air?

If only speed 4 works, and the rest produce no air movement at all. then you need a new Blower Resistor. This is what cuts down the voltage going to the blower motor to have it spin slower.

Now if it does blow air on all the settings, but setting 4 is the only one that blows cold air, then it sounds like there may be something blocking one of the little trap doors in the ducting or something to that nature, Not allowing the air to get through until you crank it up and the air eventually makes it's way through the system...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Now by the AC working only on 4. Do you mean, the blower will only blow air on 4? Or will it blow air on all settings, but only setting 4 blows cold air?

If only speed 4 works, and the rest produce no air movement at all. then you need a new Blower Resistor. This is what cuts down the voltage going to the blower motor to have it spin slower.

Now if it does blow air on all the settings, but setting 4 is the only one that blows cold air, then it sounds like there may be something blocking one of the little trap doors in the ducting or something to that nature, Not allowing the air to get through until you crank it up and the air eventually makes it's way through the system...
I only get air movement at 4.

Thank you for the help. I'll probably take it into a shop to get it replaced, I don't really trust myself to make even minor car repairs.
 
1 - 4 of 4 Posts
Top