Pontiac G6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all. I've been reading this site and threads and they've helped alot. But now I'm stumped. We hooked up an after market amp and speakers to my '09. They worked for a little while but the amp didn't have enough power to push the 12" speakers. Went and bought a bigger amp. After hooking it up, it worked for about 10 minutes and quit. We changes the remote switch (thinking it blew) hooked up a toggle switch for the amp. (Still gives the amp power) but the amp won't push thru the speakers. We disconnected the amp and hooked it up to another system and it worked great so I know it's not the amp. Theres something stopping the amp from pushing out power to the speakers. All the door speakers work just not my bass speakers.
Any help would be appreciated. Thanks!
 

·
Registered
Joined
·
868 Posts
A lot of modern amps have short circuit and over current protection. It may be worth measuring the resistance across the cabling going to the speakers that are giving problems to see if they match the the capabilities / settings of the amp (I am no expert, just an uneducated guess :) )
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
A lot of modern amps have short circuit and over current protection. It may be worth measuring the resistance across the cabling going to the speakers that are giving problems to see if they match the the capabilities / settings of the amp (I am no expert, just an uneducated guess :) )
I will try that tonight. Thanks!!
 
1 - 3 of 3 Posts
Top