Pontiac G6 Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
So the other week, I was checking my oil and realized that anti-freeze level was lower since the last time I did an oil change. It was at the full cold line, but it where it is in the picture. That picture is taken when the car has been sitting over-night.

But question is this normal??



 

·
Registered
Joined
·
2,388 Posts
If it were mine, I would have the coolant system pressure tested. That would tell you for sure if there's a leak. Or you can put some coolant dye in it & use a blacklight to see if you can find the leak. Start looking at the water pump weep hole.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #5
well if it was the water pump, wouldn't i see some coolant on the floor? I am going to take it to dealer and get them to check it, since I still have warranty left on it. I also noticed where the main belt is, all the way on the bottom it looks like a mount, and it looks kinda greasy.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #7
well update... took it in. For the coolant being a little low. They said its normal, and if it was almost empty and an leak somewhere, then for sure it is a leak. But they didn't find anything leaking for coolant

They also found the crank shaft seal leaking. Which they replaced. So question here.. when replacing crank shaft seal, which fuild do they replace as well? it is the engine oil?
 

·
Registered
Joined
·
166 Posts
Discussion Starter #9
Well guys.. guess what.. coolant reservoir is almost empty.. heard slosching whenever I would turn the car on first. Looked at it today, and was suprised how low it was.. looked under the car, shows some fluid and same on the ground. Looks like it is coming somewhere on top of where the A/C compressor is.. my guess would be water pump..
 

·
Registered
Joined
·
2,388 Posts
well update... took it in. For the coolant being a little low. They said its normal, and if it was almost empty and an leak somewhere, then for sure it is a leak. But they didn't find anything leaking for coolant.
Whoever told you that is a serious village idiot (please don't tell me it was a dealer mechanic). Measured when the engine is completely cold & the car is level, you shouldn't ever see a significant reservoir coolant level drop. If you do, there is a leak somewhere. A very simple coolant system pressure test will verify whether a leak exist or not.
 

·
Registered
Joined
·
555 Posts
I had the same problem. I had to fill my coolant every other day and could see it leaking on the ground. This happened last winter. I put some Oil Stop Leak in with every oil change and i put some of that coolant system stop leak in the coolant and havent had to add coolant for nearly a year now and no issues. I put the Oil Stop Leak in the oil because it helps with the gaskets seal. I was worried my head gasket was going out but everything is fine and never overheated and no leaks.
 

·
Premium Member
Joined
·
4,232 Posts
I had the same problem. I had to fill my coolant every other day and could see it leaking on the ground. This happened last winter. I put some Oil Stop Leak in with every oil change and i put some of that coolant system stop leak in the coolant and havent had to add coolant for nearly a year now and no issues. I put the Oil Stop Leak in the oil because it helps with the gaskets seal. I was worried my head gasket was going out but everything is fine and never overheated and no leaks.
Good thing it's been running fine... any idea where the leak may have been coming from? Reason I ask is because the water pump has weep hole(s) in it designed to leak coolant when the pump is failing or has failed, But since you're not overheating and I assume no abnormal sound then your water pump is probably fine. I just rarely hear about stop leak actually working for an extended period of time.
 

·
Registered
Joined
·
555 Posts
No problems yet. Once i put the stop leak in it stopped leaking. Hasnt overheated nor has the temp gauge gone past the normal op position. Yes the leak was coming from the passenger side of the engine compartment. Never really pinpointed it but probably the water pump.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #16
Whoever told you that is a serious village idiot (please don't tell me it was a dealer mechanic). Measured when the engine is completely cold & the car is level, you shouldn't ever see a significant reservoir coolant level drop. If you do, there is a leak somewhere. A very simple coolant system pressure test will verify whether a leak exist or not.

Well it was a service advisor that told me regarding the coolant level.. not to fond of that loser. They had to replace my key fob under warranty at one time... and that ass signed off on paperwork after service was done and decided to give me a key fob without remote start. The stupid part was I had to give them both the key fobs to program again and he returned the keys to me. I look at him (with a WTF expression) and show him the two key fob. You should see the look on his face. He was quite embarassed, but I was pissed off. So I had to bring the car in to get the right key fob.

Anyways the other update was regarding the coolant. It was a bad water pump. I am glad I bought extended warranty, and it was covered. They also replaced my key fob again since it was broken under warranty.
 

·
Registered
Joined
·
555 Posts
You know come to think of it, it was leaking more from the rear of the engine. It was coolant and a little oil. Thats why i thought it could be the head gasket. So i put stop leak in both oil and coolant and now nothing leaks and its all dried up.
 

·
Registered
Joined
·
606 Posts
You know come to think of it, it was leaking more from the rear of the engine. It was coolant and a little oil. Thats why i thought it could be the head gasket. So i put stop leak in both oil and coolant and now nothing leaks and its all dried up.
Good for you. That would not be anything I would do to my car, repair in a can.
 

·
Registered
Joined
·
555 Posts
Worked for the time being. Its been flushed out since then, still no issues.......yet.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #20
so is head gasket an issue???

I had the water pump replaced, just yesterday.. They replaced my crossover pipe gasket. Wondering if Head gasket is an issue on a 3.5L?
 
1 - 20 of 21 Posts
Top