Pontiac G6 Forum banner

361 - 380 of 381 Posts

·
Registered
Joined
·
606 Posts
Clunking noise when I steer normally at low speeds on my 2008 Pontiac G6 GXP sedan, dealership says it's the steering box which needs to be replaced at cost of over $1K. Any ideas out there ?
Sounds like IS, needs lube or replace. Connector from steering column to rack.
 

·
Registered
Joined
·
5 Posts
Problems with my G6 GXP

I haven't been having problems until recently. Front end vibration, had all 4 tires balanced and rotated but still have a slight vibration. Squeaks and a clunking noise in the steering. Squeaks were because of a steering rod, they had to remove, sand it down and grease it, after $153.00 it still squeaks, car is back in the dealership shop. Also they said the clunking noise is from the steering box bushings and the only way to fix that is to replace the steering box at over $1k, but it supposedly does not affect the steering or it being a safety hazard and if I can try to ignore the clunking. Kind of worried about that but don't have the $$$ to replace it. Other than those issues it's been a good car....
 

·
North Coast GTP
Joined
·
1 Posts
Hi all, I have an 06' G6 GTP with 96k on her. I recently began hearing this strange kind of tapping/clicking noise from the passenger side of the engine compartment. I took it to the GM dealership and the mechanics are stumped. They have used a stethoscope on a few of the idler pullies, top of engine etc. with neg. results. The oil has been changed and they ruled out lifter/cylinder issues.
Tonight I had a mechanic friend look at it and he is going to change the serpentine belt in the morning and check the bearings for the pulleys.

Has anyone experienced a similar issue? I have researched a bit, and found that it could be the crank shaft bearings. My friend says it cant be due to the mileage and my maintenance schedule.

Please help !
 

·
Registered
Joined
·
35 Posts
Bought 09 gt at 54000 mile's now have 83000. Only problem if you want to call it that was a bulb passenger side. Replaced it and a few day's later it was out again. Took it out and scraped the connection with a small screwdriver and add a little diaelectric grease and its been good for a few weeks now. Had the tires rotated and was getting a little vibration. Loosened up the lugs and re-tightened them to 100 ft. lbs. Vibration is hardly there now. Just replaced plugs, drained out the power steering and refilled.It's been a very good car.
 

·
Registered
Joined
·
5 Posts
My problems began at about 30K miles and have persisted ever since. I'm now at about 60K and spend every minute in this car regretting having bought it. This was my first, and most definitely, my last GM vehicle.
 

·
Registered
Joined
·
11 Posts
Issues with O2 Sensor

I have a 2005 Pontiac G6. I initially brought the car for 5k miles and it currently have 170k miles.

I have been having issues with replacing one O2 sensor and its the sensor 2. I have replace that sensor twice already. I brought the sensor from Auto Zone. My mechanic told me the wiring harness may be faulty.

Do you have buy GM parts for these cars? Can you use alternative parts from Part Stores. I had no issues with the other O2 sensors I brought from the part store its just this one sensor that keeps triggering my engine service light. After I change it with a new one, the engine light out will come on again in 2 months after installing a new sensor.

Any Suggestions?
 

·
Registered
Joined
·
4 Posts
Yes major problem with 06 GTP

I am new to this forum and seeking for advice. I have have a 06 G6 GTP Hardtop convertible. Engine shuts off and ABS light comes on every time I hit a speed bump, drive over railroad tracks, hit a pot hole. etc. When this happens, I would pull over the road, put it in park, and try to restart the engine. But, I would have to try several times before engine starts again. I recently noticed also that my car would not start when the weather hits near zero... yes we have been in the sub-zero weather here in Upstate NY.

Anyone out there having same issues with the G6? Any advice, suggestion, resolution is greatly appreciated.
 

·
Registered
Joined
·
83 Posts
Well I can say these cold temps are harsh on batteries. So thats why it wont start. You could always find a higher CCA battery (cold cranking amps) to help that a bit. But even mine with high CCA if it sits in the garage for a week without being ran in very cold weather. Its dead. But if started daily she usually fires right up.
 

·
Registered
Joined
·
1 Posts
I have a 2006 4 cylinder with 107k miles. Two days ago I was driving down a road at approx 45mph. Suddenly, without warning, the car shut off. I had radio still playing but no engine control at all. It hasn't started since. My initial thought was fuel filter or fuel pump and that is still what I'm leaning towards. Here's the kicker. The pump/filter are located in the tank. Now, I'm not an idiot, but come on! How is a guy suppose to just fix a problem like this? I'm hoping someone on here has had a similar problem but it wasn't the pump or filter. The check engine light came on after it died, and not before. Any help would be greatly appreciated! Thanks.
 

·
Registered
Joined
·
2 Posts
I have a horrible grinding/ticking noise that started out of my front end yesterday... Can't get an apt with gm till the 16th.. Hopefully nothing serious 06 g6 gt
 

·
Registered
Joined
·
51 Posts
My interior dome light switch is flimsy. Have it on "door" mode and lights flicker to the point that I just keep them on off.

Other than that, not bad. Small oil leak that no one can seem to pinpoint, but nothing horrible yet.
One other thing, on warm starts, after just turning the car off, it will sometimes struggle to turn over, to where I have to feather the gas for it to turn. I clean throttle body and it helps for a few months and comes back. Typical?
 

·
Registered
Joined
·
18 Posts
I have a 2006 g6 GT with multiple problems the major one being the dash pretty much doesn't light ( cluster, radio, headlights, turn signals, wipers) don't work or light up the other half of the car works. I recently put it on a scanner which it read off another vin number coming from the ECM idk why the hell someone would change out the ECM and put a SE1 ECM on a GT trim anyways I'm waiting on a WAMS ecm with my vin on it and waiting to see what happens
The second problem is that my power steering at times I turn on the car and it's hard as hell I turn off the car and start it again and it goes back to being soft don't know if maybe there is a recall for this issue
 

·
Registered
Joined
·
1 Posts
I recently went to the store and poped my trunk with no problem to put grocerys in.I came home and tried opening it and the trunk would not release.I can hear it try to open but it doesnt seem to come unlatched.The one problem is the back seat release is inside the trunk and the ignition key does not fit the trunks key tumbler.Any suggestions on how to open it?PLEASE HELP!!
 

·
Registered
Joined
·
3 Posts
transmission shift

im having a issue with my 2006 g6 convertible the odd time pulling away the tranmission make the off clunk and sometimes it seems like pulling away with brake on but it shifts great doesnt slip or anything on highway or normal shifting at normal speeds any ideas
 

·
Registered
Joined
·
2 Posts
I have been reading most of the posts on here and the majority of problems/complaints are with 2005 model year G6's. Anyone notice anything wrong or abnormal with thier 2006 yet? I have about 1000KM's on my 06 GT and do not notice anything except that at freeway speeds I am getting the slight vibration that everyone is talking about. I am going to the dealer Monday to check the balance on all 4 tires, and to double check the tightining of the harmonic balancer, just in case.
I have been reading most of the posts on here and the majority of problems/complaints are with 2005 model year G6's. Anyone notice anything wrong or abnormal with thier 2006 yet? I have about 1000KM's on my 06 GT and do not notice anything except that at freeway speeds I am getting the slight vibration that everyone is talking about. I am going to the dealer Monday to check the balance on all 4 tires, and to double check the tightining of the harmonic balancer, just in case.
Whats good,
My name is Athlone and I'm in Vegas and I got my 06 g6 gtp I got at the Euwing Bros auction 2 weeks ago and great place to get a good cheap car. I bought 3 cars from them in them past year and The g6 is a fast get IT going
I have been reading most of the posts on here and the majority of problems/complaints are with 2005 model year G6's. Anyone notice anything wrong or abnormal with thier 2006 yet? I have about 1000KM's on my 06 GT and do not notice anything except that at freeway speeds I am getting the slight vibration that everyone is talking about. I am going to the dealer Monday to check the balance on all 4 tires, and to double check the tightining of the harmonic balancer, just in case.
I have been reading most of the posts on here and the majority of problems/complaints are with 2005 model year G6's. Anyone notice anything wrong or abnormal with thier 2006 yet? I have about 1000KM's on my 06 GT and do not notice anything except that at freeway speeds I am getting the slight vibration that everyone is talking about. I am going to the dealer Monday to check the balance on all 4 tires, and to double check the tightining of the harmonic balancer, just in case.
What's good my name is a salon I live out here in Vegas and I have a G6 06 GTP and I got it from Ewing Brothers auction which is a great place to get a great car really cheap in and out the door you don't have no salesman trying to bother you do it all your own I've got three cars from them in the past year and this one is my latest to G6 and you asked if there's any problems with the G6 out there well my car is fast I will not take that away from G6 it is a get up and go to the fast moment car I love it I feel cooling it I look hot in it but anywho I'm trying to get it to pass smog and the only code that it's throwing is the fan 02 sensor or something and when I'm driving it doesn't overheat it goes to 235 but I don't know if that's where it's supposed to be sitting at temperature wise but the only code is throwing his 02 fan sensor how do I fix that is it on does it work in and when I got it it had a bunch of empty bottles of decks engine coolant in the back which concern me so I put some in it and it suck the whole first bottle I put in down so I put another another one in and filled it up where it's supposed to be and it's still at the same level can you please help me please I just registered on the site and you're the first and I saw actually and I'm thankful so thank you please help
 
361 - 380 of 381 Posts
Top