Pontiac G6 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
We have 2 G6's. Mine is a 2006 emerald green GTP. My wife's is a silver 2006 GT with the 3.5L.
We always use premium gas. Last weekend we filled up her car on the way out to our shop (14 miles away) where we are building a new house.
As I was filling up the car, (we have used that gas station many times) I got about 3/4 tank in and the pump slowed waaaaay down. Until the point where it wasn't pumping gas hardly at all any more. So I stopped pumping, thinking there was something wrong with the pump (wish I had stopped sooner!)
We drove the 14 miles to our shop with no indication of a problem. I started the car to come home that evening, and it would barely run. It was surging all the way home and the CEL was on.
Stopped at my niece's auto shop (because my code scanner was back at our shop) and she checked the code and it said O2 sensors.
So we all suspect it was the tank of gas, because we have had zero problems with this car - ever!
So I bought a can of SeaFoam and some HEET to absorb water. It's running a little better now - 3 days later, but is still really sluggish when you ask it to accelerate.
There is a filter in the gas tank, is that right? But is it only a screen?
Here is my question.
A paper-type filter can get clogged with water - which will not allow the fuel to properly flow through it.
BUT, if it's just a screen filter, then the water will eventually get sucked through it, and time alone will probably solve this problem.
Please don't tell me that all the O2 sensors need to be changed unless you are a Certified ASE mechanic and you have dealt with this at a service shop.
I taught auto-mechanics at our local high school, and have a good knowledge of how these systems work, but I need some really good advice from someone who has ACTUALLY dealt with the problem.
I don't mean to sound like a butt-head, but please don't reply if you don't actually know...
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
Why are you using high octane gas? That's what you mean by premium right?
 

·
Registered
Joined
·
90 Posts
Why are you using high octane gas? That's what you mean by premium right?
Have to agree, no need for premium gas. 'Sometimes' using a fuel way too rich will trip the sensors and major sluggishness will occur. I know, as I dealt with this problem in the early 90's when gas was much lower in price and I felt running the highest available octane in my area (93) would make my car better since it only required 87 octane according to the owner's manual. Learnt the hard way that the higher octane actually caused the system to eventually trip and yes, I had to replace not only the oxygen sensor, but all spark plugs as well. It pays to read and adhere to the manual.

Now from what you personally have stated about the slowing of the pump at the station, etc. it could very well be that you were getting gas from a tank in the ground that was running out. When you run a tank that bare, there is more to be concerned about other than just water in the fuel. The odds of you getting that much water in a tank of gas these days are extremely rare. But other factors come into play such dirt and rust particles from inside the tank you were fueling from. Could you have pumped enough of these particles inside your tank to cause such a problem? Possibly. But the instance would be rare, but not unheard of.

My advice would be to look at how many miles you have on the vehicle and decide if you are at a point where a fuel filter replacement is in order. It would also not hurt to pull a spark plug or two if you can and look for fouling.

Another option you have is to siphon out as much of the fuel as possible and place a bottle of high quality fuel injector cleaner in the car and then refuel with a good, quality fuel in your area. As for fuel injector cleaners, I would recommend 'Blaster' if it is sold at an autoparts store in your area. Simply put, in my opinion it is the very best. If you cannot find it, then Lucas Oil products has one as well that is not as good, but is better than almost all the rest on the market. Remember, if you got dirt, etc. that passed through your fuel system, then it is in your injectors too.

Good luck with getting it back up and running where it should be. Just remember to think outside the box when considering your fuel system because there are more vulnerable components besides the fuel filter and oxygen sensor.
 

·
Registered
Joined
·
163 Posts
Using premium is not his issue why are you two focusing on apples when his problem is obviously oranges?

and... ROFLMAO at "using fuel that's way to rich" I didn't know 93 octane contained more fuel per volume than 87
 

·
Courtney :]
Joined
·
179 Posts
Go to autozone and get dry gas.. not sure how much you'll need but my brothers truck had stuff poured in the gas tank and that fixed the problem.

Sent from my MB520
 

·
Registered
Joined
·
474 Posts
Go to autozone and get dry gas.. not sure how much you'll need but my brothers truck had stuff poured in the gas tank and that fixed the problem.

Sent from my MB520
He ran seafoam through it already... said it helped a little, but was still sluggish...
 

·
Courtney :]
Joined
·
179 Posts
I don't trust sea foam as far as I can through it, bad experience with that, my dad suggested the dry gas with my brothers truck, miracle I swear!

Sent from my MB520
 

·
Registered
Joined
·
90 Posts
Using premium is not his issue why are you two focusing on apples when his problem is obviously oranges?

and... ROFLMAO at "using fuel that's way to rich" I didn't know 93 octane contained more fuel per volume than 87
Hey son, when you get more experience with automobiles and what the 'wrong' gas can do to an engine, then you can ROTFLYAO all you wish. Until that time, take it easy on your elders who may have far more experience on the subject. As I do recall the OP did ask for anyone to give him advice or help who experienced the same problem at some time previous. Considering I have had the issue in the past I offered my advice and what a GM engineer told me happened to my engine at the time. So seeing that your post had absolutely nothing to do with what the OP was asking except to bust nuts on the two individuals that did offer them help, I plainly see your post as having been nothing constructively positive.
 

·
Registered
Joined
·
90 Posts
I don't trust sea foam as far as I can through it, bad experience with that, my dad suggested the dry gas with my brothers truck, miracle I swear!

Sent from my MB520

Wait! Time out! The OP obviously has an issue that already resides in his fuel system. He thinks it is bad gas and has already added one additive to it that 'should' have helped remove moisture and stabilize his fuel. To just keep telling him to add a variety of further additives to the fuel is probably not going to resolve the matter, but quite possibly make it worse. Dry gas used to be a winter saviour about 35 years ago and it was always meant to be placed in the tank to prevent any moisture in it from freezing. So dry gas is not the solution.
 

·
Courtney :]
Joined
·
179 Posts
Well it sure took poured sugar water or whatever it was out of the tank, it worked that's all im saying, there's no telling what he sucked out of the pump.

Sent from my MB520
 

·
Registered
Joined
·
163 Posts
Hey son, when you get more experience with automobiles and what the 'wrong' gas can do to an engine, then you can ROTFLYAO all you wish. Until that time, take it easy on your elders who may have far more experience on the subject. As I do recall the OP did ask for anyone to give him advice or help who experienced the same problem at some time previous. Considering I have had the issue in the past I offered my advice and what a GM engineer told me happened to my engine at the time. So seeing that your post had absolutely nothing to do with what the OP was asking except to bust nuts on the two individuals that did offer them help, I plainly see your post as having been nothing constructively positive.
You're basing your information on what someone told you to get you off their back. I have actually tuned cars and work on DPs and GS Cars from Grand-Am. Along with other custom projects. The fact of the matter is that 93 octane will not cause a rich situation. Richness is based on air:fuel. 14.7 parts per air is always the same with its 1 part of fuel regardless of 93 or 87. Higher octane allows for greater timing advance (ign). It has no effect on the AFR. The only fueling issues you will have is if you run 110 and that's just because it's leaded.

Again ROFLMAO!
 

·
Registered
Joined
·
606 Posts
The in tank filter is self cleaning. GM states they can get plugged and need to be cleaned or replaced.
I had a Cavalier get water once, it ruined all 4 injectors. My dealer fixed it under warranty. When a injector went bad white smoke came out the exhaust, raw fuel with stuck open injector.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #13
Hey all, thanks for the replies!
Here's an update! Well, the problem is getting better. We got about 2 gallons of "good" gas in it the other day, and another 1 gallon this morning. Yesterday afternoon, it was acting pretty normal. At this point, we'll keep trying to run $60+ worth of bad gas out of the car - what a waste!
I think that as we burn it off, and keep putting in fresh fuel, the problem will go away. I believe that gas station pumps filter the gas before it goes into anybody's car. However, water will "clog" up a fuel filter. That is what I think happened, too, that the main storage tank at the gas station was getting down to the bottom, and it started sucking up water. I think that's why it slowed down to the point that it would barely pump fuel.
So, IF, it was just water, then eventually we will get over the problem. If it continues to act up after this tank of gas, then I will just pull the gas tank out and see what's in there!!
Yeah, as to the discussion of octane, I know that the octane rating of fuel only affects the anti-knock characteristics of the fuel, allowing the timing to be advanced more, or in the old muscle-cars, allowing for higher compression engines without having pre-mature ignition due to dieseling.
 

·
Premium Member
Joined
·
4,232 Posts
Maybe you should go and replace the Fuel Filter just to be safe. It may be worth while to go and get an injector cleaning service done. They'll run cleaner straight through the injectors and not mix it with the gas in your tank.

I'd say try that and then re-evaluate. If some crud got sucked up it could be plugging up the filter or some injectors.
 
1 - 14 of 14 Posts
Top