Pontiac G6 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
We have a 2008 G6 with a V6 engine. About a month or so ago, the car started hesitating, almost a sharp jerking, when it gets to around 40-50 MPH. We took the car to the dealer where we purchased it and they were unable to find anything because there were no codes present. This obviously means we are imagining it, NOT. It doesn't happen every day but more days yes than no. It doesn't happen at lower speeds. Car has about 47K miles and has had all maintenance performed. Any ideas or things to look at would be appreciated.
 

·
Decepticon Extraordinaire
Joined
·
5,351 Posts
if I was guessing & it had no code I would run some Techron through the tank
thinking it was a clogged injector....
 

·
Troy
Joined
·
229 Posts
this happened on one of my previous cars, it was the spark plugs and the distributor.
 

·
Registered
Joined
·
13 Posts
Any type of miss, or lean condition, like a clogged injector will cause a code to be set. Ignition, fuel system, vacuum, or torque converter issue would be my guess, but any of the above will set a code!
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
Codes don't solve everything. I think one of my spark plugs/wires/coils is bad but I'm not going to spend hundreds finding out which one until I get a code. I had it flashing CEL for 10 seconds but it never stored a code (trust me, I have the stuff to find out).
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Thanks for the thoughts and suggestions. I will be trying some cleaner in the fuel tank to see if it's the injectors, along with some premium gas. We'll see how that goes and move forward.

Also, is the power train warranty 50K miles?
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
Thanks for the thoughts and suggestions. I will be trying some cleaner in the fuel tank to see if it's the injectors, along with some premium gas. We'll see how that goes and move forward.

Also, is the power train warranty 50K miles?
100k if I recall
 

·
Registered
Joined
·
7 Posts
The jerking happened in my car also(G6 V6 GT). Especially around 45mph. I took my car to the dealer (after they fought me on it) to find out that it was the spark plugs (whicjh BTW arent covered under warranty, so if you dont have a warranty it can de pricey if it's more than one plug.) Best bet would be to take it to a local shop to see what they would charge you to replace the plugs. Ever since they replaced the plugs everything works AMAZING and the car drives really smooth.
 

·
Moderator Member Thingy
Joined
·
1,330 Posts
The jerking happened in my car also(G6 V6 GT). Especially around 45mph. I took my car to the dealer (after they fought me on it) to find out that it was the spark plugs (whicjh BTW arent covered under warranty, so if you dont have a warranty it can de pricey if it's more than one plug.) Best bet would be to take it to a local shop to see what they would charge you to replace the plugs. Ever since they replaced the plugs everything works AMAZING and the car drives really smooth.
Just the plug? Plugs are cheap and easy to replace (except for the rear ones).

What was wrong with the ones you had? Worn? Broken shell? Faulty?
 

·
Registered
Joined
·
7 Posts
hesitation/shutter no engine code

hey guys, same issue here, I have a manual tranny 06 gtp. The car seems to hesitate in 4th gear right around 43 mph. Have no idea why. also the car seems to shutter or almost feels like i am going over small bumps in the road even though its completely flat. Could this be caused from a clogged cat? When I take the car out of gear there is no shutter. I had my throttle body cleaned, spark plugs replaced, wires replaced, had my driveline completely checked because at first it felt like a vibration but it is different. (wheels balanced, alignment, tires checked, cvs-tie rods- ball joints all checked). I feel it if I accelerate quick or cruise, and feel it more when I coast.
 

·
Registered
Joined
·
42 Posts
We have a 2008 G6 with a V6 engine. About a month or so ago, the car started hesitating, almost a sharp jerking, when it gets to around 40-50 MPH. We took the car to the dealer where we purchased it and they were unable to find anything because there were no codes present. This obviously means we are imagining it, NOT. It doesn't happen every day but more days yes than no. It doesn't happen at lower speeds. Car has about 47K miles and has had all maintenance performed. Any ideas or things to look at would be appreciated.
 

·
Registered
Joined
·
42 Posts
Several years ago, having a Olds Intrigue 3.8 L, that smillar jerking effect happened and around this speed, car on top gear. No code. In my case, that was a defective wire (cracked or burned..) A cracked or broken sparkplug would make run the engine very rough right away at any gear. This happen with a Pontiac 6000 , 2.8 L.
 

·
Registered
Joined
·
2,388 Posts
hey guys, same issue here, I have a manual tranny 06 gtp. The car seems to hesitate in 4th gear right around 43 mph. Have no idea why. also the car seems to shutter or almost feels like i am going over small bumps in the road even though its completely flat. Could this be caused from a clogged cat? When I take the car out of gear there is no shutter. I had my throttle body cleaned, spark plugs replaced, wires replaced, had my driveline completely checked because at first it felt like a vibration but it is different. (wheels balanced, alignment, tires checked, cvs-tie rods- ball joints all checked). I feel it if I accelerate quick or cruise, and feel it more when I coast.
A partially clogged cat will act like a rev limiter. If you can still snap the throttle wide open & the tach responds appropriately, it's not the cats. Checked it for codes? How many miles? You should clean your MAF sensor if you haven't lately. Yours is a very difficult problem to diagnose without seeing the live engine data.
 

·
Registered
Joined
·
7 Posts
A partially clogged cat will act like a rev limiter. If you can still snap the throttle wide open & the tach responds appropriately, it's not the cats. Checked it for codes? How many miles? You should clean your MAF sensor if you haven't lately. Yours is a very difficult problem to diagnose without seeing the live engine data.
The engine responds really well in neutral or first and second but by fourth I feel like I have lost a lot of power, obviouslythe car doesn't have as much pull in fourth, but compared to what it used gto feel likeno matter how hard I mash the gas is acts the same. I cleaned the maf with maf cleaner. No trouble codes. 82k not sure if power issue and vibration/shudder are related. Shudder feels worse when coasting. Could that be bad inner cv joints? I know outter makes a clicking sound but not sure about inner I feel they may wobble a little. Thanks for the reply
 

·
Registered
Joined
·
14 Posts
My car was jerking as well. Turns out the spark plugs and wires were just worn. I had them replaced and the jerking stopped immediately and hasn't come back. They tried to sell me some other brands but I had them put in AC Delcos.
 
1 - 19 of 19 Posts
Top