Pontiac G6 Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just bought a 2007 g6 GTP. I have found that it shakes going 65mph. I went and got the tires balanced and that didn't fix the issue. Getting the rotor's turned today. Does anyone else know what would be causing this issue? The car has after market rims MSR style 045 17 inch. There are not wheel spacers on the hubs. Could that be the problem? Please let me know what you guys think.
 

· Premium Member
Joined
·
643 Posts
Agreed with alignment. If you run it for long enough you'll notice uneven tire wear.
 

· Michigan G6er
Joined
·
217 Posts
i would also say alignment. but also might be a u joint. I had a jeep and when the u joint started to go it would shake. just an idea
 

· Registered
Joined
·
5 Posts
At any time did you get stuck in a bunch of mud? That happened to my car and the mud buildup screwed up my car and caused it to shake at around 60mph as well. My only guess other than alignment issues as well. If it is the mud...pressure wash the hell out of it.
 

· GTP 06
Joined
·
588 Posts
had same problem when I bought my car, put new ceramic pads and drilled/slotted rotors on and New Michelin's. Pricey, but after 35,000 miles they still look new and have never needed to re balance them. Also no brake dust on rims. Get what you pay for... I'll never put anything else but Michelin on any of my cars.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top