Pontiac G6 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everyone I have a 2008 G6 Gt with 50500 Miles and lately it's been stalling randomly at red lights.

This morning around 9:00 a.m. I was driving my sister to work and when we came to a red light my power steering stopped and my engine died. I had to put my car in neutral and then turn the key to start it back up. This has happen 3 times within the past 3 weeks. Right now my car has no codes so I can't really pin point what the problem is.

I have did the following things to my car: I replace my MAF sensor with a brand new OEM AcDelco one 6 days ago, car still stalls so it can't be related to that sensor. Car has a new fuel pump which was installed back july show it's still new. Took it to a shop for a vacuum leak check a week ago, mechanics didn't find any.

Now, I realized today that around late August or early September I did replace my throttle body because my old one looked dirty and had stains on the plate. Now I only had this car for 4 months but before September the car never stalled. Also the new Throttle body is an aftermarket. When I drive my car it accelerates fine and doesn't really feel sluggish, it just randomly stalls at red lights. Could it be the throttle body? I still have my old TB and I cleaned it today with tb cleaner and replaced the aftermarket one with it and so far it hasen't stalled. Or could it be something else?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Tomorrow morning I was going to test drive my car using the old Throttle Body to see if it causes the car to stall. I will also take pictures of the serpintine belt and both new and old throttle bodies.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Do you have the old TB to put back on to troubleshoot?
I put the old throttle body back on and drove around town for 40 mintutes. Car hasn't stalled yet which is a relief. I also noticed the car idles a little smoother at stops now. I'm probably gonna drive around with the old tb for about a week and see if it stalls the car. I'm starting to think the aftermarket tb is the reason for my car stalling.
 

·
Registered
Joined
·
9 Posts
The belt may not have proper tension... Aka slipping. It's usually due to poor materials in the belt manufacturing or chemicals on the belt


Sent from my iPhone using Tapatalk
 

·
08 convertible
Joined
·
200 Posts
A slipping belt cannot cause the engine to stall.

Keep the old TB on. Drive the car and see what happens.
 

·
Registered
Joined
·
11 Posts
Also best not to clean T.B.. At most just a good wipe down on the air cleaner side. You can use T.B. cleaner but don't spray into the intake/T.B. butterfly. Just spray on a rag and wipe it down best you can.
 

·
Registered
Joined
·
9 Posts
A slipping belt cannot cause the engine to stall.



Keep the old TB on. Drive the car and see what happens.


It did on the G6 I had, the belt wasn't spinning the alternator and causing the car to die giving it fuel from the light.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
62 Posts
Does you scan tool do scan enhanced codes? I just posted a new thread about my 08 stalling at a red light and P1682 , ignition circuit, popped up. I know some scan tools may not read all codes, just a thought. Did you get your issue resolved?
 
1 - 12 of 12 Posts
Top