Pontiac G6 Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter · #1 · (Edited)
I cant seem to find the problem with my car that is throwing these codes. If you guys have any ideas, they would be greatly appreciated! ever since my car threw this CEL, my car has been shifting pretty rough. but it doesnt shift hard all the time, sometimes its smooth and sometimes its rought. The CELs are P0171: system too lean, bank 1 and P0174: System too lean, bank 2. please help!
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #2 ·
ok since no one has run into this problem it seems, i googled it. and it turns out that most of the time its from the MAF sensor needing to be cleaned. does this make sense to anyone? ive never heard of a MAF sensor needing to be cleaned. anyone have an opinion on this?
 

·
Registered
Joined
·
292 Posts
I've heard that aftermarket air filters like a K&N cone filter has oils in it that can cause dirt to stick to the MAF sensor if it manages to leak through. Don't know if this is true or not though. Suppose its possible but it didn't stop me from buying one, LOL!
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #5 ·
i made it myself. i used 3 in pipe and bent it to match up with the stock tubing. then i just used couplers from oreillys to connect it all to the filter i also got from oreillys. the filter sits right behind the fog light. i cleaned the maf sensor and it seems to run better, but the cel didnt go away. does anyone know if there is a way to adjust the fuel pressure? or maybe i need to replace the fuel filter? and i did check for leaks, i also had a friend help me do this to have another set of eyes on it. and we didnt find any leaks in it.
 

·
Premium Member
Joined
·
5,786 Posts
Its your intake. Put the stock one back on. Pull the battery for awhile then hook it back up fire it up and see what happens.

What engine do you have?

Fuel filter is in the tank. Its a liftime one.

Pix would help
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #10 ·
sorry man i didnt realize it was rocket science to click on the "5" next to the word gallery under my pic.... either way, i shortened up the intake. it no longer goes down into the fender well, the filter now sits where the stock air box used to be.
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #12 ·
well i drove her around twice. turning her off and letting her sit for about 15 min between drives. each time i drove about 10-15 miles. and CEL seems to be gone. (keeping my fingers crossed). but is it possible that thing was too long for my cars liking?
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #14 ·
yeah that pos is now gone lol i used that bc i didnt wanna pay 15 bucks for a coupler that would fit on my MAF sensor, and i had a home depot gift card. but xmas cards have came in the mail and i broke down and spent the money for the two couplers. i got em from speektek up here in the ft worth area. and they fit perfectly.... you gotta pay to play so to speak.
 

·
Registered
Joined
·
142 Posts
Hey Lampoon, your cai's wouldn't do that....LOL...anyway K+N wont get you the same power as a crab air intake would...advertising fer you pooners! But its true. HOw much power gains do you get from your intake anyway pooners? Like 7 hp right??? And also what about the front pipe upgrade...make any difference???
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #16 · (Edited)
i like to do all my own work. i dont wanna go buy an intake that everyone else has, and every once in awhile you run into a problem you cant figure out. thats why i joined this forum. to get help if i need it and maybe help out a few ppl at the same time if at all possible. and if you have a problem with that paramount then keep your comments like that to yourself. i didnt ask if the crab intake would give me this problem or what the power gain differences are.

and the CEL came back on after i ran to walmart (about 10 miles each way) and got back home and put it in park. I've never dealt with an o2 sensor, but its there a way to check and see if its bad and needs to be replaced?
 

·
Registered
Joined
·
142 Posts
What about my comment was offensive?? If it was taken offensively than i am sorry, I didn't mean for it to be like that. THats the problem with the internet, tone of voice is eradicated. No I read your post and it reminded me of his intakes and I just wanted to know his numbers, thats all.
 

·
Registered
Joined
·
142 Posts
OH and another thing, bring your car to a gm dealer. I know it seems like the easy way out but I have heard of other issues like yours, same problem. The dealer says that a quick visit will fix u up. SOrry but I don't have any other better advice.
 

·
Registered
Joined
·
156 Posts
Discussion Starter · #19 ·
im sorry, i thought you were trying to say something negative by the term "pooner". but it looks like i may have to take it to a dealer which sucks bc they're not cheap and im one of those broke med school students. lol
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top