Pontiac G6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Any takers? What is happening here? If it is simply the sensor from the cargo top hook near the trunk light, how do i fix it? Help!
 

·
Registered
Joined
·
480 Posts
That is usually what it indicates, it is not sensing the switch pressed in when the cargo cover is in place. You could try checking the cover to make sure it is aligned correctly, use an ohm meter on the switch to make sure it is working.

I have used a paper clip in the switch terminals when I have taken the plastic side covers out. In the same line of thinking you could tape over the switch in the depressed position to see if the roof would operate. Please remember that neither of these are a fix and you are defeating a key safety feature until you remove these tests.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Boomer. Is this sensor/relay easily removed and replaced? Is the part available? Where from? Is this a generic part that any electric supply stocks? I don't wish to open a panel up unless I feel I can fix it. And a multi-part question. Thanks
 

·
Registered
Joined
·
480 Posts
I believe you mentioned it in the start of the thread. It is a switch on the right hand side of the trunk as you look in from the rear. Near the light. It gets pushed in by the end of the trunk cover when it is hooked into place. I have not tried to replace it. I have taken the side panel off. In that case there is a wire to the light and a wire to the switch, both of which have a connection that can be removed. Hope you get it fixed.
 

·
Registered
2008 Pontiac G6 GT Convertible
Joined
·
3 Posts
In mine, the bar you pull on the cargo cover was bent. I bent it back and the problem went away. If nothing else, checking that could save you some $.
 
1 - 5 of 5 Posts
Top