Pontiac G6 Forum banner

1 - 20 of 29 Posts

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #1
today i noticed my car was sluggish. It started.driving normal shortly.after..then i was on the highway using cruise control and upon going up a hill my rpm shot to 5000 and the car did nt accelerate and my engine light.started flashing. I turned the cruise off and tapped the break and everything returned to normal and the light has been off since. Any ideas??
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #3
2006 2.4ltr. Is it the cat extended warranty letter i got in the mail last year?

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Registered
Joined
·
2,388 Posts
Even if the CEL is off there may still be a pending code/s in the computer. If not, a decent scan tool(not a code reader) can display the misfire data & tell you which cylinder/s is/are involved.

It's misfiring under a high load (pulling uphill). You really need to find out which cylinders are involved.

A clogged cat is a possibility.
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #5
Is it possible the tranny is slipping? God i hope not. I guess ill let the dealer scan it. I believe autozones scanners only detect codes when the check engine light is on.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #6
Also I've had seemingly loss of power and not as great gas.mileage in the past. I've changed the plugs in it at 70k. There are 94k on it now.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #7
Also, what rpm should it idle at? Right now it seems to idle right at a grand. I can't remember but that seems a tad high.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Registered
Joined
·
2,388 Posts
800 rpm is normal.
When was the last time the MAF sensor & throttle body were cleaned?
A clogged cat in that 2.4l will give you a consistent feeling of sluggishness though it is definitely more noticeable as engine load increases.
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #9
I had a fuel system cleaning at 50k and 75k. I bet its the cat. I have an appointment Monday morning. Ill update you. Hands for all your help.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #11
At 60 k I hAd A cylinoide in the throttle body replAced i believe

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #12
Well the dealer couldn't find anything. The stored code said it misfired in all 4 cylinders. Its running fine now. So i guess i do nothing from here. Its a bit irritating but i guess I saved some cash.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Registered
Joined
·
2,388 Posts
Well the dealer couldn't find anything. The stored code said it misfired in all 4 cylinders. Its running fine now. So i guess i do nothing from here. Its a bit irritating but i guess I saved some cash.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
I'm assuming they pulled a 300 code (multiple cylinders misfiring). Something tells me you haven't seen the last of that issue.
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #14
He didn't specify but i agree, its not the last of it. Maybe ill get lucky and assume i got bad gas since i filled up before i started having problems.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #16
Ok i have an update today...... Chk engine light came back on and read codes p0171 and p1133. Any info????

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Registered
Joined
·
2,388 Posts
Ok i have an update today...... Chk engine light came back on and read codes p0171 and p1133. Any info????

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
Finally some hard evidence. Replace the precat O2 sensor.

Given the car's mileage, I'd normally just replace both O2 sensors now.
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #18
Will do, have an appt Friday. I will update after.

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Keep it factory baby!
Joined
·
100 Posts
Discussion Starter #19
Great news. Dealer said it was the catalyc converter. No charGe for me!

Sent from my SAMSUNG-SGH-I717 using AutoGuide.Com Free App
 

·
Registered
Joined
·
2,388 Posts
Given 94K engine miles & a clogged cat I'd replace that upstream O2 sensor now since they have to remove it anyway to replace the cat.
 
1 - 20 of 29 Posts
Top