Pontiac G6 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2007 Pontiac G6 GT question...I have been pulling a P0420 code for a couple months and no matter what I try it will not go away. I have changed the plugs, the fron 02 sensor and the passenger side catalytic converter and I wanted to try and find an answer before I spend anymore money.

The car drives fine, even better now with the new cat, but now I am pulling a P0174 code along with the P0420. If anyone can shed some light on my situation it would be much appreciated!!
 

·
Registered
Joined
·
2,388 Posts
2007 Pontiac G6 GT question...I have been pulling a P0420 code for a couple months and no matter what I try it will not go away. I have changed the plugs, the fron 02 sensor and the passenger side catalytic converter and I wanted to try and find an answer before I spend anymore money.

The car drives fine, even better now with the new cat, but now I am pulling a P0174 code along with the P0420. If anyone can shed some light on my situation it would be much appreciated!!
How many engine miles & which engine?

Did the 174 pop soon after you did some engine work?

At first glance, the issues appear unrelated, as they are on diff banks.

So far you've replaced the bank 1 cat & the bank 1 pre-cat oxygen sensor.

For the new P0174 (bank 2 over lean threshold):

First clean the MAF sensor if you have not.
If no joy, it's likely you have an intake air leak post MAF in bank 2. A smoke test is often successful in finding intake leaks. Possibly a breach in the manifold gasket or head gasket.
If you have done any engine work or mods, revisit those closely.
A scan tool with live data would be very helpful in analyzing both of these issues.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It has the 3.5 engine in it and yes it was only about 50 minutes after replacing the cat. I cleared the code and so far no engine light has come back on. I have another question for you though. I have another g6 gt coupe with no engine light and it is jerking and sputtering at constant speeds. Dealer said run injector cleaner and I did and it helped a bit but still is present. Any thoughts?
 

·
Registered
Joined
·
2,388 Posts
It has the 3.5 engine in it and yes it was only about 50 minutes after replacing the cat. I cleared the code and so far no engine light has come back on.
A new cat can pop a 420 during the first 100 miles.

I have another g6 gt coupe with no engine light and it is jerking and sputtering at constant speeds. Dealer said run injector cleaner and I did and it helped a bit but still is present. Any thoughts?

Not until codes pop.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7 (Edited)
mad and upset

No I got the cat from magnaflow and now I'm pulling P0420, P0174, and another one this is past rediculous! Everything I try adds another error code!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
About to drive it into a lake!

I was still pulling P0420 along with other codes for 02 sensors. I replaced ALL of the sensors and the catalytic converter this weekend...LIGHT CAME ON THIS MORNING!! I took it to the muffler shop, called the dealership, asked everyone I knew and they said it was the cat. I just don't know what to do anymore. I have another G6 GT with only 50,000 miles if this is a sign of things to come I may just go ahead and sell it!:mad::mad::mad::mad::mad::mad::mad::mad:
 

·
Registered
Joined
·
9 Posts
Check for proper ground

just my 2 cents,

I had been having the check engine light on for over a year. At first it would be intermittent, but after 6 months it was on all the time. The weird thing was that the car was running just fine.

This weekend I started trouble shooting the issue on a recommendation from a friend to check the ground connections for proper connection. I found one in the trunk fuse/relay box in the trunk. I noticed that the cable that connected to the box appeared to be burnt. I replaced the connector and repaired the cable and all the codes have gone away. Its been 3 days now with no check engine light.

I hope this helps!
 

·
Registered
Joined
·
2,388 Posts
I was still pulling P0420 along with other codes for 02 sensors. I replaced ALL of the sensors and the catalytic converter this weekend...LIGHT CAME ON THIS MORNING!...
It might help if I knew which O2 sensor codes it popped. Since replacing all four O2 sensors, have the O2 sensor codes now cleared after significant driving?

You're saying you replaced the bank 1 cat a second time now?

Is the engine still running well?

You still have the 420 & 174 both reappearing?
 
1 - 11 of 11 Posts
Top