Pontiac G6 Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter #1
Ok so I don't always hear it. Some days it will come on after I start my car and some days it's fine. It's louder underneath the steering wheel. When I got my car it didn't come with the keyless entry so I had the dealer put one in. I don't know if that would have anything to do with it. I'll try to post a video of it so you can hear what it sounds like.


Sent from my Autoguide iPhone App
 

·
Registered
Joined
·
31 Posts
Is the car throwing any check lights or codes? If so you could have it run at most local autoparts stores and if they cannot tell you what it is, they can give you the code. A quick call to your local dealer and they can tell you what the code is for.

Would have to hear the noise and have more details to further my guesses on the problem. lol. (not this biggest mechanical expert, but try to help anybody anyway I can)
 

·
Registered
Joined
·
189 Posts
Discussion Starter #4
theres no check lights or codes and i dont think its the fan. im putting the video up in a second so you can hear for yourself
 

·
Premium Member
Joined
·
4,232 Posts
I sometimes here a clicking as well. Though it seems to be coming from the passenger side fuse box. I hear it while braking or something. I'm pretty sure it seems to be coming from the blower motor. But can't be too sure, never investigated it and bothered to figure it out haha.

I'm interested to hear how it sounds, maybe it similar and we can finally get to the bottom of it
 

·
Registered
Joined
·
189 Posts
Discussion Starter #6
hah get this.. i was going to upload the video from my iphone but i had to restore it because it messed up (no joke) so whenever it does it AGAIN ill upload it. It almost sounds like a signal clicking sound and at first i thought it was because my seatbelt wasn't clicked but it still does it. like i said you'll know what im talking about when i can get a video up.
 

·
Registered
Joined
·
189 Posts
Discussion Starter #9
no it starts clicking when i turn the key on... it has not done it again but when it does ill show you.
 

·
Registered
Joined
·
189 Posts
Discussion Starter #10
Okay. It finally did it again. When I get home I'll upload the video so you can hear it.
 

·
Registered
Joined
·
2,388 Posts
Sounds like your turn signal warning audio (also used for the hazard lamps). In the G6, the audio is generated in the instrument cluster itself in response to instructions from the BCM. The cause could be tough to track down. So you had keyless entry or remote start installed? Either way, I'd have to wonder if that played a role.
 

·
Registered
Joined
·
189 Posts
Discussion Starter #13
Sounds like your turn signal warning audio (also used for the hazard lamps). In the G6, the audio is generated in the instrument cluster itself in response to instructions from the BCM. The cause could be tough to track down. So you had keyless entry or remote start installed? Either way, I'd have to wonder if that played a role.
yeah i had keyless entry. i don't know if they set it up right because you know when you lock the car and the horn beeps and there's the acknowledgement ding? (also when you turn auto lights off) well i have to lock the car with my door open to get the horn to beep when it locks. if i lock it with the remote it doesn't beep and there's no acknowledge ding. so i'm thinking that the keyless entry has something to do with the whole thing.
 

·
Registered
Joined
·
2,388 Posts
If the problem began right after the install of keyless entry then there is a high probability that caused it. Either way, you're at the mercy of a dealer with this because only they can see what the BCM is doing using their Tech 2.
 

·
Registered
Joined
·
189 Posts
Discussion Starter #17
Well so I asked the dealer who installed the keyless entry for them. And took it to the place to let them look at it. I go back Tuesday so they can take their time and find out what the problem is.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
54 Posts
Ok the sound is coming from the turn signal flasher in your fuse box.

Most likely you have a short somewhere due to the Keyless entry install. If they used the wrong power source wires for the Keyless entry module then it would cause power to be sporadically be sent to the flasher causing the flasher to think it is getting a signal but it isn't getting enough current to cause the blinkers to flash.

When you take it in I would have the head electronics technician at the dealership check over the original technicians install job make sure they didn't splice into the wrong wire during your install and make sure the tech used the right source wires.

let me know if this helps. Just curious I noticed your from Oklahoma. What dealership are you taking it to?
 

·
Registered
Joined
·
189 Posts
Discussion Starter #20
I got the car from Ferguson. But they had Car Trends install the keyless entry so I'm taking there again Tuesday.


Sent from my Autoguide iPhone app
 
1 - 20 of 27 Posts
Top