Pontiac G6 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 G6 3.5L. Electrical systems starting failing like remote key entry failed. Security lock light and low fuel light come on while driving. Car electrical is dead, lights will not even come on. After troubleshooting I was able to find that the plug connector on the engine management computer is the issue. If I put pressure on the connector everything will start working. Is this a known issue and is the problem more than likely the computer connectors, plug connector or a wire breaking in the harness?
Note: Car has a new battery installed as part of troubleshooting.
Neat troubleshooting tip I figured out. When fault happens the hazard lights will not even work. I turned the hazards on and starting messing with the cables. When the hazards actually started flashing I had found the area of the failure.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Further troubleshooting appears to show that there is ground connection issue internal to the engine management computer. The case of the computer is directly connected to ground (negative of the battery) through internal connections and the large ground pin in the left plug. Opened the computer and inspected the solder joints for the plug connectors. There are a few suspect solder joints but ring out as good with Ohm meter. This is a multi layer board and the connection issue could be on the top traces of the computer board.

Next test will be to connect the case of the computer to the negative battery terminal when the problem happens. If this clears the problem then I will replace the computer and go from there.
 
1 - 2 of 2 Posts
Top