Pontiac G6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I bought the car a year ago, top has always been slow closing. Tried taking it to a top shop and they scratched head.. never saw a hard top. Now last summer started stopping when deck lid starting to raise when putting down (usually goes fine when putting up), but I get out and lift deck lid a bit when it stops and it will pop and continue fine.. except in the middle it will stop once or twice so I release button and hit it again and it continues. Last night to put up I had to help deck lid, then it started to lift back cover and froze. Would not move up. I put it back down some and hit up again and nothing. Put all the way down and tried again it would start to go up again... repeat. Finally tried moving to more level surface and after a couple tries it went up.., but still stopped once when pushing button and restarted after release and press. Afraid to put top down for fear it won’t go back up. Suggestions?
 

·
Registered
Joined
·
176 Posts
I'd start by checking for fluid leaks in the vicinity of the main hydraulic cylinders. If you see evidence, then check the fluid level in the hydraulic pump. (It's behind the right-hand trunk side panel.) There's a full or "Max" mark on the reservoir where the level should be. If you have leaking cylinders, they'll need to be repaired to solve the problem. There's a vendor named Top Hydraulics (www,tophydraulics.com/78-pontiac) that's well regarded for their repairs.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
I did check that last year and a couple weeks ago as well when well was open anyway to install backup camera.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Update. Took to dealer and paid for initial diagnostic. Not communicating with bcm. Could be the power switch (in stock for $48 but I knew I could get it for less than half that so ordered)... or a couple other parts that are discontinued. They have 3 others sitting there for weeks with top issues unable to get parts. I told them not to dx further and I ordered the part I could. If that doesn’t fix it, I have found one of the parts they mentioned (module) it could be -used. The pillar switch would be the last thing I try to find and replace. At least I know it is electrical as I thought.
 
1 - 4 of 4 Posts
Top