Pontiac G6 Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a coolant leak that I have traced to a hole in the bottom of the recovery tank. Has anyone else had this issue and is there a fix for this. I can't get another recovery tank till Friday next week.
 

· Registered
Joined
·
103 Posts
my waterpump just went out and before it went out it started pissing from the tank,yes the bottom i thought it was a hole but learned that when our cars start to overheat the bottle relieves the pressure from the bottom of the tank,my water pump went out about two days after i noticed the leak.and the waterpump was covered under the 100,000 mile warranty fyi.
and no epoxy the hole is there for a reason
 

· Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Mine isn't over heating yet but i will watch it closely. I just got home and checked it and it wasn't coming out of the bottom of the tank right now. It did it this moring when I was filled it back to the cold mark. I started it up and about 2 minutes later it started dripping pretty bad so I shut it off and waited for an hour. Hasn't done it since but will look at it again tomorrow.
 

· Registered
Joined
·
103 Posts
yeah i came out and saw a big puddle filled then started and as soon as the thermostat turns on it will start again.yeah mine stopped for a bit also thought it was fine then when i went across town for dinner it overheated,i had to tow the damn thing home so yeah be cautious i would take it to the dealer asap if it keeps dripping
 

· Registered
Joined
·
5 Posts
I have a coolant leak that I have traced to a hole in the bottom of the recovery tank. Has anyone else had this issue and is there a fix for this. I can't get another recovery tank till Friday next week.
The hole in the bottom of the tank is the overflow. Try replacing the cap before the tank. You'll pay over 50$ for a new tank, 6$ for the cap. I had the same problem and the cap fixed it.
 

· Registered
Joined
·
32 Posts
Just putting this out there in case anyone else has a similar problem... for over a year I had a coolant leak, the car never ran hot, I never smelled coolant or saw any on my driveway etc, but my low coolant light was constantly coming on... every time I would have an oil change, about 2 weeks later the light would come on until I topped it up again...

I took the car in at least 3 or 4 times for the same problem and every time they insisted they could not find a leak. This was to the dealership under regular warranty. On the 4th or 5th time they said they found a hose with a leak, replaced the hose, and for a couple of months I had no problem. This would be during 2009....

In January 2010.. all of a sudden the low coolant light started coming on again.. I took it back in, this time to a different dealership as my pontiac dealership had closed. They found a "crack in the radiator" and replaced the "entire radiator"... anyway... a few days later.. same problem... turns out the new radiator also has a crack in it... so they had to get another new radiator and put that in... no problems since and it has been several months...

The car only had 34,503 miles when the radiator was replaced...

Part # Replaced: 15873468 Radiator
Cost: 402.50 Labor/413.52 Parts
Paid by extended warranty company.

Complaint: low coolant warning light stays on

Mechanic notes: pressure test or leakes - radiator leaking at side tank.
 

· Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
It ended up being the crossover gasket. It stilled leaked the first time after they fixed it out of the piss hole in the bottom of the tank but has never done it since. I keep watching it everyday or so but so far so good.
 

· Registered
Joined
·
64 Posts
hey all, I myself have this issue on my 07 Sedan. I just traced it to the bottom of the tank or one of the hoses below it. Would the tank be covered under the 5/100 warranty? I have my car scheduled to go in on Friday of next week
 

· Registered
Joined
·
1 Posts
Hello, I have an 07 gt sedan and have had both the head gasket and the water pump replaced under warranty around 76k miles after it was overheating, I am now at 86k miles and had to pull off the interstate because my engine got too hot and powered down...the coolant cap was gone and hose was disconnected, I'm taking it into the dealership tomorrow to see whats going on with it, I looked around online to see if anyone else has had issues and found this post. I love my 6 but hate that I've had so much trouble out of it....anyone else having these kinds of problems?
 

· Registered
Joined
·
64 Posts
I had an issue with coolant loss(no lost cap) but the tank was leaking. I bought the tank and cap for $38 shipped(thanks Amazon!).

Replaced both fairly quickly, topped up and it was fine. The way the hose was attached to the previous tank left me concerned as it wasn't all the way up male part of the tank and the clamp wasn't in a solid spot. Thinking back though the cap was more likely the cause but safer than sorry.

My ongoing issue is the brakes/rotors. I had them replaced 2k miles ago and they are WARPED(deposits) again. I drive like grandpa, no hard breaking. Wheels need balancing again too(stupid roads in NJ).
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top