Pontiac G6 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Filled the reservoir up with coolant, car ran fine for a couple of days. Noticed the heat stopped working while the car was sitting again, checked and the reservoir was dry again. Any idea where to check for a leak? Any common places on these cars? Noticed it's difficult to get to the radiator. Any tips on getting to the radiator? Thanks in advance for your help
 

·
GTP 06
Joined
·
588 Posts
before I bought my car, there was a leak on the right side of the radiator. made the dealer put a new one in before I bought it.. Always take the car home and inspect every part before buying.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Bought the car new in 2006, it's just now having problems and I believe the warranty is up (not sure tho). I believe the heat is due to low coolant because it works when your driving and that's what everyone said on other forums, and when I filled the coolant back up the heat worked fine while the car was parked for a few days.
 

·
Varsity Squad
Joined
·
751 Posts
I would look under the car for puddles, then top off the fluid, then start it up and let it run and get up to tempature so the thermostat opens, then look all over the engine for leaks and puddles, if none visible, take for a SHORT test drive, park the car and check again also smell the exhaust for burning coolant (head or intake gasket can cause this), if still nothing shut car off and let sit for about 10 mins and check again. You are right about the heat, it will not work right if there is not enough coolant in the system, only place I heard of a coolant leak on these was the waterpump, but that doesnt mean that is your issue. Good luck, hope this helps.
 

·
Registered
Joined
·
31 Posts
If anyone has a coolant leak first thing id look at is the water pump, these G.M. Water pumps are known to go bad around 50000 miles and its a weeping leak that comes from a bad bearing in the water pump. And before you spend 350$ to fix it check a dealership to see if you have the 100000 mile warranty like i found out.
 

·
Registered
Joined
·
2,388 Posts
If anyone has a coolant leak first thing id look at is the water pump, these G.M. Water pumps are known to go bad around 50000 miles and its a weeping leak that comes from a bad bearing in the water pump. And before you spend 350$ to fix it check a dealership to see if you have the 100000 mile warranty like i found out.
The 5 yr/100k mile powertrain warranty (includes the water pump) covers all '07 & newer vehicles.
 

·
Registered
Joined
·
317 Posts
this just happened to me, i smelled coolant in my car right when i started it up... took a look at i the next day and took it in, first thing the guy said was a water pipe.. like said earlier known to go bad around 50k ( i have 53k on mine) gotta call today said could be possible blown head gasket :(
 

·
Registered
Joined
·
2,388 Posts
this just happened to me, i smelled coolant in my car right when i started it up... took a look at i the next day and took it in, first thing the guy said was a water pipe.. like said earlier known to go bad around 50k ( i have 53k on mine) gotta call today said could be possible blown head gasket :(
On your '06, you'll be out-of-pocket on that repair. Not a small sum for a head gasket. You can put UV dye in the coolant & probably verify the leak source for yourself just to be sure you aren't getting BS. UV dye is cheap & so is a blacklight to see it.
 

·
Registered
Joined
·
317 Posts
well from the dealer i got it from, it came with a 3 year warranty and apparently it is gonna be covered so that's good for me, i guess
 

·
Registered
Joined
·
3 Posts
I have a 2008 G6. I have replaced the hose and water pump. I'm losing antifreeze on the front right side where the tire is located. I found antifreeze sprayed on the area where the belt is located in top of the engine and side. Also antifreeze sprayed on top of the case that houses the air filter. On the cover of that case is little puddles of antifreeze. Then puddles under the car on the right side. I've seen several drips in different spots but in the same area after I drive my car and it sits. Once I turn it off and let the car sit the dripping stops but then I have to fill my reservoir again. Drips happens after either driving the car or sitting. Spraying happens while driving. Please help!
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top