Pontiac G6 Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
OK it is almost everyday now. I drive 65 miles one way for work. mostly freeway driving, I set the cruise and about 1/2 to 3/4 of the way to work the cruise shuts off and is totally inopp. for anywhere from 10 minutes to the rest of my drive. Also when this happens, almost everytime but not everytime, the trans will kick down to 5th gear and the torque converter will lock and unlock. Its a strange combination of events but has anyone had similar or some events that sound like this?

I talked to a service writer at the dealership that I get my oil changed at and he said it sound like a module or electrical problem (but thats pretty much a given being its a GM product). Of coarse there is no MIL light on so who knows how long it will take to trace the problem.
 

· Registered
Joined
·
15 Posts
I was not receiving any codes but had issues with cruise, power locks and remote start. It was imtermittent problem that made it hard to diagnose. Check to make sure everything else is working properly. I discovered that the auto door locks didn't lock when I moved the shifter into drive and didn't open when moved back to park. The cruise did not work, the remote start wouldn't work and the transmission did not shift smoothly. After 3 trips to the dealer they found a (TSB) technical service bulletin that told them to reflash the (ECM) computer. Dealer completed this last week and issue was resolved.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top