Pontiac G6 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My dashboard gauges work then stop working then start working again. Everything reads zero even when I am driving. Yesterday it was doing this then today it fine. The temp gauge will randomly be the only thing moving..it will run to hot then back to cold and stop working. Has anyone had this problem and if so where you able to fix it? I looked online and have seen where others have had this problem yet the mechanics can't figure out why...HELP!!!! also my car doesn't want to start sometimes...it will turn over but not start..then it starts. I wonder if these are connected??
 

·
Registered
Joined
·
2,388 Posts
My dashboard gauges work then stop working then start working again. Everything reads zero even when I am driving. Yesterday it was doing this then today it fine. The temp gauge will randomly be the only thing moving..it will run to hot then back to cold and stop working. Has anyone had this problem and if so where you able to fix it? I looked online and have seen where others have had this problem yet the mechanics can't figure out why...HELP!!!! also my car doesn't want to start sometimes...it will turn over but not start..then it starts. I wonder if these are connected??
MY, engine & mileage could be helpful. Instrument cluster backlighting is unaffected? Did the two complaints start more or less at the same time? Engine cranking is strong? Are any of the instrument cluster indicator lamps lit up after engine start? How long since the complaints began?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
mileage is 54,000 and it is a V6 engine. the dashboard lights and gauges went off for a couple seconds then came back on. when they came back on the gauges did not work..they were reading zero but i was driving. the problem with the car not starting began about a month ago. It acts like it is starting then doesn't. It doesn't do that all the time
 

·
Registered
Joined
·
2,388 Posts
mileage is 54,000 and it is a V6 engine. the dashboard lights and gauges went off for a couple seconds then came back on. when they came back on the gauges did not work..they were reading zero but i was driving. the problem with the car not starting began about a month ago. It acts like it is starting then doesn't. It doesn't do that all the time
Did you check for DTC's? ALWAYS do that first. Even if the MIL is unlit.

Intermittent electrical issues are by far the most difficult to troubleshoot. Unless you are (at the very least) a shade tree mechanic with good knowledge of multimeter use you will need help with this. The two complaints could be related or not. There are quite a few possibilities for an intermittent crank-no start condition. It's probably worth it to have a dealer put the tech 2 on it & get a diagnosis. You may be able to do the actual repair yourself.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
If the check engine light is not on will it give a code? They have always said in the past when I took my other car there that if the check engine light is not on they won't get a code.
 

·
Registered
Joined
·
2,388 Posts
If the check engine light is not on will it give a code? They have always said in the past when I took my other car there that if the check engine light is not on they won't get a code.
DTC's can be pending. The computer decides if the condition warrants lighting the MIL. But a pending code can give you a clue what's happening. No one should be without a basic code reader anymore considering they are so cheap.
 

·
Slick Black Pontiac
Joined
·
151 Posts
I believe that there is a fuse for the gauges behind the kick panel on the passenger side of the center console... I would check that fuse first.
 

·
Registered
Joined
·
13 Posts
My dashboard gauges work then stop working then start working again. Everything reads zero even when I am driving. Yesterday it was doing this then today it fine. The temp gauge will randomly be the only thing moving..it will run to hot then back to cold and stop working. Has anyone had this problem and if so where you able to fix it? I looked online and have seen where others have had this problem yet the mechanics can't figure out why...HELP!!!! also my car doesn't want to start sometimes...it will turn over but not start..then it starts. I wonder if these are connected??
Does this issue keep happening to you? I have a 2006 V6 and this exact issue happened to me today for the first time (95k miles). I have also had the starting issue for some time...but it always ends up starting, I thought I had read somewhere that that issue was common and was not a big deal. This dashboard thing is weird. I have also had my radio tell me it was locked before...turning the car off and then starting back up fixed that. I really hate GM.
 

·
Premium Member
Joined
·
4,232 Posts
I have never run across an intermittent fuse in my life...but never say never I guess.
Believe it or not I found the fuse boxes for these cars aren't too good. I put a fuse tap in one and it was enough to bend the tab in the fuse box preventing the fuse from making contact. ended up having to put a piece of wire in to keep it all snug. So far so good... but so lame that I had to do that.
 

·
Registered
Joined
·
2,388 Posts
Believe it or not I found the fuse boxes for these cars aren't too good. I put a fuse tap in one and it was enough to bend the tab in the fuse box preventing the fuse from making contact. ended up having to put a piece of wire in to keep it all snug. So far so good... but so lame that I had to do that.
Fuse taps should be outlawed for that exact reason. They very commonly ruin fuse holders. And if it's in the cabin fuse box/BCM it requires replacing the BCM itself. Much safer to do a proper wire tap with an inline fuse.
 

·
Registered
Joined
·
1 Posts
I have this same issue. If the gauges aren't working when I fist turn the key on, it will not start nor even turn over. Not sure what is causing it, but I did find an odd way to correct it for the moment. While holding the key in the START position, tap the horn and it will reset whatever is causing the issue. I may have to this several times one day and maybe not again for a couple of days. I think the antitheft isn't communicating correctly with the BCM. I am leaning towards the BCM as the radio doesn't shut off when I open the door either. I also noted that while listening to AM radio programming that their is a light chirping wound while the gauges are out. Goes away when the gauges come back on.

mwlaue
 

·
Premium Member
Joined
·
4,232 Posts
Things not turning off when you open the door could be a faulty door switch, which is built into the door latch. They've been known to fail, especially on the driver's door.

however the BCM could still be at fault. Perhaps cleaning and greasing the connectors with dielectric grease could help.
Some of what you describe also sounds like a weak battery situation. If your battery is known to be good I would go and check all the grounds and other connections. Make sure they're all clean and tight. You may be chasing a few different issues that all stem from one bad connection.
 
1 - 16 of 16 Posts
Top