Pontiac G6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
my 09 g6 starting acting up a few weeks ago. when driving the transmission doesn't slip but it seems like its not shifting into the next gear on time. when in drive the car will move forward and engage but when it has to shift into the next gear it doesn't. the rpms get high to maintain the speed its at. when I put it into the manual mode or sport mode the car drives fine. when I am controlling the timing of the shift it shifts right away and driving fine but in drive the shift is delayed. I've seen places that it could be a shift solenoid or a transmission speed sensor. I just want to confirm that its this before starting work on it and I wanted to see if it s something different besides these and if anyone else has had this problem
 

·
Registered
Joined
·
97 Posts
Is the CEL illuminated? Stop at any of the "box store" pars stores(AutoZone,O'reilly's, AdvanceAuto) and have them retrieve the code(s) from the cars computer and post them here. May also be caused by need to have the trans oil and FILTER changed....
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
There are no lights on we have a code reader as well and we changed the filter gasket and all new trans fluid
 

·
Registered
Joined
·
97 Posts
Well you've"covered the bases" of my initial thoughts! But the Speed sensors going awry would throw a code, particularly since you report it is a constant non "automatic"shift problem.
What size motor in your ride?
Also have read from threads here that there can be a problem with the oil pick up tube cracking and not able to suck in sufficient quantity of oil for trans operation. I'm kind of new here myself and more of a MOPAR GUY.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I have a 3.5 4 speed. Ya we also were thinking it could be the gear sticking or somthing but after new fluid it didnt change
 

·
Registered
Joined
·
3 Posts
I had a similar problem in my 06 GTP. Turns out it was the lock up that was busted. Since it was the only thing wrong with the car, everything else perfect, I decided to bite the bullet and take it to a transmission specialty shop. They rebuilt it and it shifts perfectly now (it was very pricy though!) This might be on the extreme end of solving your problem though.
 
1 - 6 of 6 Posts
Top