Pontiac G6 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an 09 2.4L G6. About two weeks ago I noticed that my AC wasn't working and the check engine light came on along with the temp needle not registering. My cooling fans stayed on constantly from key on. It would sometimes come back and fix itself. About a week ago, I went to run some errands. The car started up, went to my first location and turned it off. Started right back up. Went to my second location, did the same thing. Went to the gas station turned it off to pump gas and when I went to start it - nothing. The odometer read error. Can the ECT cause this error. The shop said it could be a bad ecm that I would have to take it to the dealer. And can a bad ECT fry a computer. I know my starter works because it turns when I ground it out at the relay. But I don't hear the relay engage when I turn the key. Any ideas would help.
 

·
Registered
Joined
·
344 Posts
Sounds more like multiple problems and not just singular cause. The A/C. rad fan and lack of temp gage point to a stuck open thermostat Code(s) in the P- - - - format being posted by you would be much help in getting responses.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
If i remember the code, it was p0128? The description was that it was taking too long for the car to heat up.
 

·
Registered
Joined
·
344 Posts
If i remember the code, it was p0128? The description was that it was taking too long for the car to heat up.
YES that code would relate directly to a stuck open Thermostat and not too bad to replace. It will also cause the other symptoms of which you posted.
as far as the error message, that I can't help much on especially not knowing of past maint. history or battery condition.
 

·
Registered
Joined
·
25 Posts
I have an 09 2.4L G6. About two weeks ago I noticed that my AC wasn't working and the check engine light came on along with the temp needle not registering. My cooling fans stayed on constantly from key on. It would sometimes come back and fix itself. About a week ago, I went to run some errands. The car started up, went to my first location and turned it off. Started right back up. Went to my second location, did the same thing. Went to the gas station turned it off to pump gas and when I went to start it - nothing. The odometer read error. Can the ECT cause this error. The shop said it could be a bad ecm that I would have to take it to the dealer. And can a bad ECT fry a computer. I know my starter works because it turns when I ground it out at the relay. But I don't hear the relay engage when I turn the key. Any ideas would help.
hey! may not be 100% your problem but very very similar at least for the no start and error, i was driving doing door dash got out turned car off came back no start with error. turned out a ground cable literally fell off the side of the engine block, only difference is i have the 3.5l, but car was at 56k miles and has next to zero rust. check grounds! :)
 
1 - 6 of 6 Posts
Top