Pontiac G6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2005 g6 and am having some odd problems with it. Has anyone run into any of the following issues or know if they could be related to one problem? Within the last month the following things have stopped working:
The trunk will not open with the button on the drivers door or with the remote. I can hear it click but it does not open.
The remote start quit working. The lights will flash but it will not start. I found a sequence of stuff to turn on and off and such to reset this function. After doing so the car would start but as soon as the starter caught it would die.
The childproof window lock no longer works.
The door lock/unlock doesn't seem to work very well. I have to be right beside the car and hold the button for a long time before it will do anything. I've changed the battery in the remote and it still does this.
Sometimes when i unlock the doors the horn will beep 3 times, not a big deal but it's something new that it's started to do.
The front speakers are very quiet. I thought maybe the speakers were blown but they aren't crackly/staticy at all, they're just very quiet.


Does anyone have any suggestions that i could try before taking it to the dealership and paying a fortune for them to run test?
 

·
Registered
Joined
·
422 Posts
As for the remote start, have you verified that the remote start option is enabled in the DIC? Is the check engine light on?

The trunk not opening is probably the release mechanism. You can hear it trying to release so clearly the signal is being sent.

The door lock/unlock could be the contacts in the remote

And the car chirping three times when unlocking could mean that the alarm was triggered

Has the car been in any accidents?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I have checked the DIC and it is turned on. I've disabled it and then turned it back on and no luck. The check engine light is not on either.

A couple weeks after the trunk quit working it suddenly started working again for about two days. Then went back to just clicking.

Is there anything that i could do if lock/unlock is the contacts or would I need to purchase a new remote?

I replaced the car battery around 9 months ago as the old one died on me so I know this one is good.

Last winter it was in a minor accident. A lady cut me off in the ice and I rear ended her. It wasn't too hard though, just minor scuffs on the front bumpter.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top