Pontiac G6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 06 gtp, and have some slipping like a shutter, upon left turns mostly but some when I turn right. I originally thought it was the transmission. Had it pressure tested and it has no codes in the history. So I started looking at drive axle shaft slipping due to gear shearing in the transaxle. Nothing found. I noticed an electrical plug on the rack... electronic power steering! Check the fuse box and the 80 amp eps fuse is not there at all. What am I missing
17493
dash and I have ever yet to locate a steering assist box anywhere on the steering shaft.
17491
17492
 

·
Registered
Joined
·
74 Posts
I'm fairly new to the GM line, and only recently got an 08 gt(3.5L),. From what I understand the GTP you say you have should have the 3.9l motor and uses normal hydraulic power steering like my slightly newer 3.5l gt. Hence no 80 amp electric steering fuse, so that means you have some other problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It is in fact a 3.9l motor, I thought for some reason they had turbos thus the gTp ...but mine sure don't. Lol. I even went a looked at 07 with a 3.4 and it had a different setup than mine. Frustrating to no end. Doesnt do it all the time either. If it was the transmission it would slip all the time. This is a left turn prominent issue. I have never noticed it going straight down the road. The traction control button does nothing when is pushed so i am leaning towards guessing the traction control module? I guess I'm going to start with installing the factory stereo back into the car so I can at least get the dummy messages. Thanks for the reply
 
1 - 3 of 3 Posts
Top