Pontiac G6 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Ok, I've had my G6 for nearly two years (purchased Sept '04) and have had no problems--until today. I left work @ 5pm and ran a couple of errands. I was headed home afterwards so I can go work out at the track. On the way, I notice that the car was beginning to fight left and right turns some. Just flat out protesting against it. So I was like oook. Then all of a sudden, it starts to squeak and creek, really loud, coming from the front-left tire. I mean, it sounded like it came straight from the junk yard! And it was embarrassing, a still new-looking car (believe me, the car is clean all the time. lol) sounding like a pile of junk being pulled across the pavement. So I called the dealership and explained to them what happened and how it sounds and made an appointment for tomorrow morning. So I'll let everyone know how things turn out when I get all the good and bad news...
 

·
Registered
Joined
·
71 Posts
As stuuupid as this sounds, take it in and have them check the serpentine belt. My 05 was squealing and the steering was jacked up and they said the squealing was the belt which there is a TSB out for. Hope that helps!
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
Thanks for the advice, guys... So this is what happened. It was raining like cats, dogs, and just about everything else when I woke up the next morning. When i started my car, I didn't notice any sound at all. I turned the steering wheel left and right and heard nothing. I pulled out of my garage and still heard nothing. I drove to the dealership, still raining and, to no surprise, they told me that it would be a little difficult to hear anything with how bad it was raining. My dad had got off work and met me their, just in case they needed to keep the car, I'd have a ride home (or take a loaner, didn't make a difference). But since it wasn't making any noise, and the rain wasn't helping any, I went ahead and made an appointment for a day next week. Hopefully, it'll be a dry day. But I drove it to work this morning and back home, and didn't hear anything. No pulling, no nothing. Smooth and quiet ride, all the way...
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
Ok, so I brought the G6 in yesterday morning, as it was the brightest and sunniest day forecasted for the week. Made no noise going in, of course, but that didn't matter. I just wanted things to be checked out so I can find out just what the heck was going on. So they gave me a loaner (G6 V6... is it me or does G6 V6 protest against acceleration, almost everytime??? Steering was good and it moved quickly to 30, 35, but I almost had to stomp the pedal to get it moving past that) and I used it yesterday and today...

They found the problem and it was: rack and pinion. Cool. So they know what the problem is and had to order a couple of parts for it. So I picked my G6 up today and they even worked on my panoramic sunroof--as I didn't even complain about it. One of the engineers noticed it was making some noise and took care of it. So I drove all the way home (about 30 minutes) and just as I pull into the garage, RATTLE, CRANK, RATTLE... It sounded like metal being mangled together and rolled down the street. <sigh>. So I called the dealership up and told them that the noise was back and just as loud. Now I gotta bring it back again, tomorrow morning.
 

·
Registered
Joined
·
50 Posts
If you get this before you take it in... take it down a gravel road. See if the noise is constant/occuring a lot more. If it is, tell them to replace the intermediate steering shaft. If they buck, tell them to look up the TSB's for the Cobalt with similar steering system. I rented a G6 V6 in Vegas that was making a lot of noise in the steering and it was the exact same noise I've heard in a handful of 2005 Cobalts and the 2006 Pursuit I drove on Friday. It's a metalic rattle-type sound and you may also be able to duplicate it by wiggling the steering wheel back and forth really quickly when you're stopped.
 

·
Registered
Joined
·
916 Posts
WOW u know your stuff!
Built4drivers have u had people come in with a squel in the (serpentine?) belt when the engine revs past 3k i took it in and they told me they couldnt replecate it and i noticed that on the TSB somewhere in the forums i saw something that said high rpm engine squeal/odor should i go in and give them this number because it seems they dont want to fix it and it is really loud and i have almost 30,000?

Sorry i went to this question in the bansee wheel post....just need help
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
I believe bigbengt67 got it right: it was in fact the wheel bearing. So it was inspected, replaced, and lubed up again. I'm just glad the wheel didn't go flying off while driving! Thanks everyone for the input. Greatly appreciated.
 

·
Registered
Joined
·
1 Posts
By any chance would you remember how much it cost to get the wheel bearing replaced? I think I'm having the same problem and I'm going to go get it checked out soon.
 
1 - 16 of 16 Posts
Top